firefox doesn`t respond, Can't force quit.

VERIFIED DUPLICATE of bug 246789

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 246789
14 years ago
14 years ago

People

(Reporter: droca, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; es-es) AppleWebKit/124 (KHTML, like Gecko) Safari/125.1
Build Identifier: 

After my first try of Firefox, two Firefox applications icons are shown on the Dock. One of them doesn`t 
respond (firefox icon flashes in the Dock). I tried to force quit, but it doesn´t work. THe firefox icon 
flashes on the Dock. I can't turn off the laptop.
Maybe it is a problem of having used the app in the virtual installation disc, instead of the one I 
dropped onto the Applications forlder.

Reproducible: Always
Steps to Reproduce:
1. See Firefox icon flashing on Dock. Try to click on it and a "Try to force quit" message appears
2. Choose "Try to force quit"
3. Try to force quit in the standard alt-com-esc window. (Firefox icon also flashes in this  window)
4. try to drop Firefox virtual installation disk on the Trash
5. Try to turn off the laptop.
Actual Results:  
Nothing.
Message "The trash cannot be emptied because Firefox is running"
Message "No turn  off because Firefox is running."
Cul de sac.

Expected Results:  
Quit and leave me alone. I just want to uninstall and forget about the program.

Comment 1

14 years ago
if ever it crashes like that:

1. Pull up a Terminal
2. ps ax | grep "Fire"
3. kill that process

doesn't help you too much (but it works better than alt-com-esc)
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> if ever it crashes like that:
> 
> 1. Pull up a Terminal
> 2. ps ax | grep "Fire"
> 3. kill that process
> 
> doesn't help you too much (but it works better than alt-com-esc)

Sorry, but I can't follow you. First I don´t know how to type the "vertical dash" character. I tried with / 
instead, and a bunch of strange commands came out.
Secondly, I don't know how to kill a process.

Thank you for your help.

The pipe character "|" is normally Shift+\ (backslash).

Once that command is typed in the terminal, pressing enter should shut down Firefox.

If I understand correctly, this occurred on your very first start of Firefox?
Did a "TalkBack" screen appear? Is there any more information about the install
process or your system that would be relevant?

Comment 4

14 years ago
The same problem happens to me when I install Firefox. It crashed and reloaded about once 
per second so it couldn't be force quited. I tried to restart, but Firefox blocks it. The only thing 
I could do was shutdown using the power button on the case. I have all the OS X updates 
(10.3.5) and I downloaded the most recent version of Firefox. It first happened a few months 
ago, but when I tried installing it again, the same thing happened. I hear Firefox is great, but 
it isn't getting off to a good start with me.

Comment 5

14 years ago
the command "ps ax" lists most running processess (including the fox)
"grep irefox" will select just that proc containing the string: irefox
  (I left out the "F" because it may/may not be uppercase)
"|" the pipe "filters" the output of ps to the grep command, showing
   just the firefox process
To kill the process, you need the PID (process ID number) which is
    the number all-the-way at the left of the output.
To kill it:
type:  kill -HUP PID
       (where PID is that number)
-HUP is a signal -- which you could also try: kill -9 PID

also see:
man ps
man grep
man kill
This will harness you a lot of power on the Mac

I believe the problem is that firefox was not properly installed.
I don't have a Mac, but I hope someone can clarify how to install
properly. (I think it has something to do with dragging the install
file somewhere - and NOT running the install directly from the origonal
downloaded file)

Thanks for your valuable input


(In reply to comment #3)
> The pipe character "|" is normally Shift+\ (backslash).
> 
> Once that command is typed in the terminal, pressing enter should shut down
Firefox.
> 
> If I understand correctly, this occurred on your very first start of Firefox?
> Did a "TalkBack" screen appear? Is there any more information about the install
> process or your system that would be relevant?

*** This bug has been marked as a duplicate of 246789 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.