Critical update cannot be installed as user. Installling as root deletes all settings.

VERIFIED DUPLICATE of bug 236593

Status

()

Toolkit
Application Update
--
critical
VERIFIED DUPLICATE of bug 236593
14 years ago
10 years ago

People

(Reporter: Walter Neumann, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040924 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040924 Firefox/0.10.1

Firefox reports a critical update. When I try to install it it fails. 
If I reload Firefox as root (using "sudo firefox") I can install the update, but
all bookmarks and other settings are gone when I restart Firefox.

Reproducible: Always
Steps to Reproduce:
1.give command "sudo firefox"
2.run the requested critical update
3.exit firefox.

Actual Results:  
On reloading Firefox all bookmarks and settings have been deleted. 
It seems step 2 above is not necessary to have this happen (but step 1 seems to
be necessary to install the critical update).

Expected Results:  
Bookmarks and settings still there (I lost months worth of stored bookmarks,
passwords, etc.)
Possibly related: bug 262670, bug 230032 comment 14.

*** This bug has been marked as a duplicate of 262653 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

14 years ago
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 236593 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Ah, good catch.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.