Downloaded DOS executable file (.exe) cannot be deleted on Desktop if download is canceled

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
major
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Timothy Weaver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 04/09)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

After downloading DOS executable files (to any folder), the executable file can
be copied and run but any attempt to delete the file results in a Windows
message that the file is in use and cannot be deleted. A reboot of the operating
system still gives this problem. Only a reboot to Safe Mode will allow a manual
delete of the file. This happens only with DOS EXE files downloaded in Firefox.

Reproducible: Always
Steps to Reproduce:
1. Download a DOS EXE executable file with Firefox.
2. Attempt to delete the file from the Windows Explorer or Command Prompt.
3. Receive error that the file is in use.


Actual Results:  
Windows states that the file is being used by another process. A reboot of the
OS still does not allow the file to be deleted.

Expected Results:  
The file should be deleted. I believe that Firefox is doing something that flags
the file in a way preventing Windows from deleting it. This only happens to
files downloaded with Firefox.
what dos file, url ?
(Reporter)

Comment 2

13 years ago
Any DOS file from any site will do, but if you need an example you can use:

http://us.creative.com/support/downloads/download2.asp?Product_ID=1842&dlcentric=273&Product_Name=Sound+Blaster%AE+16&OSName=DOS


However, this has happened across multiple files and sites.

Comment 3

13 years ago
Reproducable under win2k sp4 when saving to either a ntfs or fat32 drive
->NEW
->MAJOR (understatement ?)
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040930 Firefox/0.10.1
(MOOX M3)

WFM

Comment 6

13 years ago
I don't see how this can be a Firefox problem. I was able to duplicate the
problem with the example file given. However, using Process Explorer shows that
explorer.exe is what is holding handles open on the file, not Firefox. I think
this is a Windows problem - I seem to remember seeing this happen with IE before..

Comment 7

13 years ago
Just some more information for those who work on this, I defraged my hard drive
the other day an have found that i can now delete the file that this bug
mentions. I used norton system works rather that the windows defrag as well. i
dont know if there would be a differance or not.
(Reporter)

Comment 8

13 years ago
Just to confirm this still happens with the 1.0 release.

One other thing I checked is to do a Scandisk (with a reboot) on the NTFS
partition. This did not resolve the problem.

I also tested on a completed different download file (still DOS EXE, which is
the only type that seems to cause this problem). I extracted the files from it,
including the DOS EXE files included inside the file (it was a self-extracting
file, obviously). This problem does NOT occur with those files. I can delete
those files just fine. The original DOS EXE is, however, still undeletable
unless you go into a safe mode command prompt to manually delete the file.

I understand that it does not seem like this could be a Firefox problem, but as
it is only happening in Firefox (and consistently) it seems like something
possible to track down. Of course, I wouldn't rank the problem that high as it
has a workaround and probably is very rarely encountered.

Comment 9

13 years ago
*** Bug 271224 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
*** Bug 279702 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Summary: Downloaded DOS executable file cannot be deleted → Downloaded DOS executable file (.exe) cannot be deleted on Desktop if download is canceled

Comment 11

13 years ago
*** Bug 279831 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

13 years ago
Just so everyone is clear, you CAN delete the file but you must reboot to
maintenance mode to do it.

Comment 13

12 years ago
*** Bug 325158 has been marked as a duplicate of this bug. ***

Comment 14

12 years ago
In reply to "reboot to maintenance mode":

It is possible to delete the file without rebooting. To do so, kill explorer using Task Manager (or the process manager of your choosing) to free the lock, then run a shell from Task Manager, delete it with the shell, and restart Explorer. Clean, quick.

Perhaps this is getting locked because Firefox uses the Win32 API's HTTP download functionality, and Windows is getting confused? WebClient, isn't it? I'm throwing that out there, Firefox is probably smarter than that as a product.

Comment 15

12 years ago
And for the record, this happened for me with a GUI subsystem (i.e., non-DOS) executable. It does not appear to be limited to DOS executables, simply any aborted PE file ending in .exe will do.

Comment 16

12 years ago
I have experienced this bug as well, but with general exe's.

This bug has occured three times to me, and it seems to happen when,

     1. start a new download
     2. X out of the download manager window
     3. close out of firefox

When I attempt to delete the half downloaded exe from desktop, I get
a message that it is in use by another program. 

Comment 17

11 years ago
Sometimes this file can be deleted by opening notepad and throwing a few ASCII characters into the /empty/ exe file (I've only seen this file empty after an aborted download). Reboot, possibly more than once, and the file can be deleted. You would think after a couple of years that this bug would be addressed.

Comment 18

11 years ago
Reassigning to default assignee & QA contact in the vague hope that people might get mail about it or bored people searching nobody's bugs someday might be interested in further researching it.
Assignee: bugs → nobody
QA Contact: ali → download.manager

Updated

11 years ago
Duplicate of this bug: 282037
anyone still seeing this?
Whiteboard: CLOSEME 04/09

Comment 21

10 years ago
Seems to be resolved with xp sp2 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/2008031114 Firefox/2.0.0.13
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Comment 22

9 years ago
=> WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.