Thunderbird display is awfully broken with a XUL error box

VERIFIED FIXED

Status

Thunderbird
Mail Window Front End
--
blocker
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: Frederic Bezies, Assigned: bsmedberg)

Tracking

({fixed-aviary1.0, regression})

unspecified
x86
All
fixed-aviary1.0, regression
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041003 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041003 Firefox/0.10

Simple to reproduce. See below.

Results is a list of XUL error in the bottom of the windows, no menus at all.

XUL Errors are :

   <Broadcaster ID="Communicator:Workmode" /
---^
    
    <key id="key_selectAll" key="&selectAllCmd.Key;" modifiers="accel"/>
----^

    <menuitem id="context-selectall"
----^

    <menuitem id="popupwindow-reject"
----^

I hope this not to be already known :]



Reproducible: Always
Steps to Reproduce:
1.Grab aviary branch code and keep it up-to-date
2.Build thunderbird
3.Launch it

Actual Results:  
Xul errors in bottom ; no menu bar.

Expected Results:  
Giving a working workplace ?

.mozconfig used with MS VC++ 6.0

. $topsrcdir/mail/config/mozconfig

ac_add_options --enable-optimize="-O1 -G6"

ac_add_options --enable-static
ac_add_options --disable-shared

ac_add_options --disable-debug

ac_add_options --disable-auto-deps
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.0+

Comment 1

13 years ago
what thunderbird build are you running?
(Reporter)

Comment 2

13 years ago
right now ?

A 2 days old homemade one.
(Reporter)

Comment 3

13 years ago
Confirming display bug, using a cleaned profile and "official nightly" build
from there :

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-0.8/

Using build posted at 07:51 this morning.
also see this with 2004100306-0.8 on linux.
Keywords: regression
OS: Windows XP → All
QA Contact: trix
this regressed btwn yesterday's build 2004100206-0.8 (works) and today's build
2004100306-0.8 (broken).

Comment 6

13 years ago
cc'ing Benjamin. I just sent him e-mail about this. 

Comment 7

13 years ago
Where's communicator/locale on the branch?  Trunk is still busted too, since the
global-region dtds/properties are being put in US.jar which Thunderbird doesn't
ship.
(Assignee)

Comment 8

13 years ago
Created attachment 161008 [details] [diff] [review]
do repackaging properly
Assignee: mscott → bsmedberg
Status: NEW → ASSIGNED
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Comment 9

13 years ago
Created attachment 161163 [details]
It's not yet completely fixed.

Comment 10

13 years ago
This seems to work well in 20041005 - AVIARY on XP.
bug 262842 covers comment 9.
vrfy'd with tbird 2004100606-0.8 bits on linux fc2.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.