Allow to view all events in current display in unifinder

RESOLVED FIXED in 1.4

Status

--
enhancement
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: k_b0000, Assigned: Taraman)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041001
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041001

sorry for the poor summary. please rename to something better.
using the 20040924 build in mozilla (linux).
high up on the calendar is the "contain" filter textarea.
just to the left of that i a dropdown list that specifies which events to show
in the event pane above the calendar.
i would like to add an option that states:
All events visible in calendar.

why would this be good?
if you use the multiweek view, and have one or two passed weeks in your view,
there is no good way to have the events pane to show the events from those
weeks. choosing All Events, is to much, but choosing any other view does not
help much if you need the last few weeks events for reference.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

14 years ago
Severity: normal → enhancement

Comment 1

14 years ago
Furthermore, I would appreciate a Thunderbird-esque "Customize.." view whereby I
could create specific filters to list events based on combinations of
catogories, calendars, dates or whatever. 

Thanks! 

Updated

13 years ago
QA Contact: gurganbl → general
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
Component: General → Sunbird Only
OS: Linux → All
QA Contact: general → sunbird
Hardware: PC → All
Summary: allow to view All events in current display → Allow to view all events in current display in unifinder
Unifinder is also available in Lightning now.
Component: Sunbird Only → General
QA Contact: sunbird → general
Marking WFM based on comment #3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(In reply to comment #4)
> Marking WFM based on comment #3.

I only changed the component from 'Sunbird only' to General. You can't show 'all events currently visible in calendar view' in the unifinder.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

10 years ago
it would be nice to pick events by specific dates, or at the least last month. Or maybe user selected criteria in unifinder.
(Assignee)

Comment 7

8 years ago
I think, such an option would be a good addition.

I would call it "Events in current View"

I will also have a try to implement this.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

8 years ago
Assignee: nobody → Mozilla
(Assignee)

Comment 8

7 years ago
Created attachment 592513 [details] [diff] [review]
proposed addition V1
Attachment #592513 - Flags: review?(philipp)
(Assignee)

Updated

7 years ago
Keywords: uiwanted
Comment on attachment 592513 [details] [diff] [review]
proposed addition V1

Looks good to me. What kind of additional UI is needed for this, as you set uiwanted?
Attachment #592513 - Flags: review?(philipp) → review+
(Assignee)

Comment 10

7 years ago
I thought maybe the menulist is getting a little crowded and wanted to have an opinion from the ui-guys.
But if you think that is not needed, I go ahead and check it in.
Well, you could use separators to split up similar view types (i.e all of the "The next..." views between two splitters). Since its trivial to do that, I'd give a blanket r+ if you want to include that into your patch.

Otherwise I'd also be fine with a new bug for that, or a second patch on the bug.
(Assignee)

Comment 12

7 years ago
In that case I'll push and think about the splitters again - if so in a different bug.

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/f14e9fd13faf>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3
(In reply to Markus Adrario [:Taraman] from comment #12)
> In that case I'll push and think about the splitters again - if so in a
> different bug.
> 
> Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/f14e9fd13faf>
> 
> -> FIXED

comm-central is 1.4, not 1.3 (comm-aurora)
Keywords: uiwanted
Target Milestone: 1.3 → 1.4
You need to log in before you can comment on or make changes to this bug.