Adding a new search engine - no text description for new engine, upon selecting the engine logo, firefox crashes.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Kris Silver, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

When I try to addy any engine through the 'add engine' option in the search bar,
it add's the engine, without any text (just a logo) when I then select this
engine, Firefox performs a general windows crash, so I get the 'firefox has
errors and must close' type standard message.

This has been reported through the automatic 'talkback' agent.  I have tried
removing all extensions, un-installing, re-installed the latest build, going
through the painful process of removing FF registry keys, or any left over
files, and the problem still persists.

Reproducible: Always
Steps to Reproduce:
1. On the search bar (top right) select 'add engines'
2. add any, new engine
3. select the new engine

Actual Results:  
Firefox crashed.  Basic windows crash box, saying FF has errors and must close.

Expected Results:  
selected the newly installed search engine, and allow it to be searched like any
other engine.  

This problem did not happen on 0.9.3, I dont remember if I un-installed 0.9.3
before I installed 1.0PR but I have completely removed anything mozilla from the
pc as far as I can find, including the profiles, several times.  Still using no
extensions and the problem persists.  It should at least now work as it should
when I expect to be literally installing FF again, as if it were the 1st
download, as I had removed everything.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041003
Firefox/0.10

WFM

any searchplugin in particular ?
It may be related to an extension (I suspect TBE or TBP).
Disable all and see if it still happens.

If it still happens Uninstall Firefox and try a new build 
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.9/


I tried with 20 different searchplugins and they all work fine.
setting WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

13 years ago
I have just downloaded the latest nightly, and FF no longer crashes in this 
way.  I will see how it goes.  This does not mean  1. The issue is non-existent 
2. It has been resolved 3. That it does not need to be looked into further.

It is worthy of looking into further when Firefox crashes, with no extensions, 
worked fine on 0.9.3, and complete un-installs, re-installs, & new profiles did 
not fix the problem.  I thank you for your promt assistance, but just because 
you can't re-create the problem on your computer, OS, version, does not mean 
there isnt a conflict on mine and others computers.  There was obviously 
something in FF conflicting with my PC, OS, or settings in some way, when it 
shouldn't have, & until it's known why it may well happen again, be it current 
or future builds.  Due to that fact that I firmly believe only upgrading to 
this build has solved the issue, I believe the issue is still in other builds, 
and needs looking into to ensure it doesnt occur in the same or worser ways in 
future builds.  The answer to the problem may be hard to find or re-create, but 
that does not it's been understood, and fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

13 years ago
It's now happened on the latest nightly (4 Oct).  In options>Advanced..I 
pressed CHECK NOW for updates to FF and extensions.  Within seconds Firefox 
crashed, in almost precisely the same way.  Windows gave the Firefox has errors 
and must be closed message, Talkback agent came up, & I filled it in, sent it 
off.  Don't know the reference # for it, & I just tried to re-create the 
problem but this time it did not crash.

Comment 6

13 years ago
wfm current cvs trunk build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.