Reproducible crash on clicking "Back" [nsSHEntry::nsSHEntry(nsSHEntry const&)]

RESOLVED DUPLICATE of bug 262183

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 262183
14 years ago
13 years ago

People

(Reporter: Aleksey Nogin, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
To reproduce:

1) Go to http://lib.aldebaran.ru/author/lukyanenko_sergei/
2) View -> Text Zoom -> 150% (not sure whether this is relevant)
3) Click on one of the book links, for example -
http://lib.aldebaran.ru/author/lukyanenko_sergei/lukyanenko_sergei_donyrnut_do_zvezd/
4) Click on "Читать книгу" -
http://lib.aldebaran.ru/author/lukyanenko_sergei/lukyanenko_sergei_donyrnut_do_zvezd/lukyanenko_sergei_donyrnut_do_zvezd__0.html
5) Go to
http://lib.aldebaran.ru/author/lukyanenko_sergei/lukyanenko_sergei_donyrnut_do_zvezd/lukyanenko_sergei_donyrnut_do_zvezd__1.html
(either by clicking on "1", or by editing the location in the URL bar - does not
seem to matter).
6) Click on "back".

Most of the time, I see a crash. gdb shows (but this is optimized build, so it
might be inaccurate):

(gdb) bt
#0  0x4162cdd0 in nsSHEntry::nsSHEntry(nsSHEntry const&) () from
/usr/lib/mozilla-1.8a4/components/libdocshell.so
#1  0x415ffca3 in nsDocShell::FindTarget(unsigned short const*, int*,
nsIDocShell**) ()
   from /usr/lib/mozilla-1.8a4/components/libdocshell.so
#2  0x415fcb7f in nsDocShell::ConvertLoadTypeToDocShellLoadInfo(unsigned) ()
   from /usr/lib/mozilla-1.8a4/components/libdocshell.so
#3  0x4112a585 in nsFrameLoader::~nsFrameLoader() () from
/usr/lib/mozilla-1.8a4/components/libgklayout.so
#4  0x4114d1d6 in nsGenericHTMLFrameElement::LoadSrc() () from
/usr/lib/mozilla-1.8a4/components/libgklayout.so
#5  0x4114d22d in nsGenericHTMLFrameElement::SetParent(nsIContent*) () from
/usr/lib/mozilla-1.8a4/components/libgklayout.so
#6  0x410e9880 in nsGenericElement::AppendChildTo(nsIContent*, int, int) ()
   from /usr/lib/mozilla-1.8a4/components/libgklayout.so
#7  0x4119c7b9 in SinkContext::OpenContainer(nsIParserNode const&) () from
/usr/lib/mozilla-1.8a4/components/libgklayout.so
#8  0x4119f918 in HTMLContentSink::Init(nsIDocument*, nsIURI*, nsISupports*,
nsIChannel*) ()
   from /usr/lib/mozilla-1.8a4/components/libgklayout.so
#9  0x414e0ac2 in ?? () from /usr/lib/mozilla-1.8a4/components/libhtmlpars.so
#10 0x44225f28 in ?? ()
#11 0x0d4b0b20 in ?? ()
#12 0xbff101bc in ?? ()
#13 0x414e0b4f in ?? () from /usr/lib/mozilla-1.8a4/components/libhtmlpars.so
#14 0x00000558 in ?? ()

I am running BuildID 2004092711 (trunk) gtk2, built and running on Fedora Core 2
 + all updates.
Chances are, this is bug 262183 (fixed on the Sept. 29th).  Could you test a
Sept 30 or more recent build, by any chance?
(Reporter)

Comment 2

14 years ago
No longer see this with 2004100400

*** This bug has been marked as a duplicate of 262183 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.