If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

incorrect display of HTML comments

VERIFIED DUPLICATE of bug 174862

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 174862
13 years ago
13 years ago

People

(Reporter: James Perreault, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The comments are in: <html><body><div><div style="float:right"><div>
and it's the first tag in that 3rd div

This comment displays starting with "-- BEGIN"
<!-- BEGIN -- This is an HTML comment and should not show -->

This comment doesn't display at all (correct)
<!-- BEGIN This is an HTML comment and should not show -->

On further investigation... adding a <!-- END -- text here --> makes NOTHING
display between the comments.

Reproducible: Always
Steps to Reproduce:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>Page Title</title>
</head>
<body>
<div class="header">
	<a href="www.mozilla.org"><img src="images/logo.gif" alt="" width="55"
height="55" /></a>
	<h1>Site title</h1>
</div>
<div class="clearing">&nbsp;</div>
<div id="wrapper">
	<div class="container">
		<div id="main"><p></p>
			<!-- BEGIN -- This is a comment and shouldn't display -->
			<div class="class1"><img src="images/image1.gif" /></div>
			<h1 id="topic">Main Title</h1>
			<h2>Title</h2>
			<p>
			Paragraph 1
			</p>
			<p>
			paragraph 2
			</p>
			<!-- END -- This is a comment and shouldn't display -->
		</div>
	</div>
	<div id="nav">
		<ul>
		<li></li>
		</ul>
	</div>
<div class="clearing">&nbsp;</div>
</div>
<div id="footer">Copyright &copy; by me</div>
</body>
</html>

Actual Results:  
incorrect browser rendering.  try adjusting the -- after BEGIN or END and see
the results.  I'm using Firefox PR1.0 (and just downloaded a critical update)

Expected Results:  
check IE... I hate to say it, but IE displays this (one and only) thing correctly.

it appears to have something to do with me putting BEGIN and END in my comments.
 i was blocking out an editable region for my own purposes when I noticed this.
 Hope this is news to you, and not a waste of your time.  thanks

Comment 1

13 years ago
Your comments are invalidly formed, which is why the display is breaking.  You
cannot put -- in the body of a comment, because that closes the comment.

See http://www.w3.org/TR/html401/intro/sgmltut.html#idx-HTML

*** This bug has been marked as a duplicate of 174862 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.