Mozilla 1.7.3 does not launch after Windows XP BSOD

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: dwymi02, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
Build Identifier: Mozilla/1.7.3 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

After a successful install of Mozilla 1.7.3 I had my Mozilla browser running
when my XP machine crashed with a BSOD.  Ever since then Mozilla will not
launch.  I have not been able to locate and messages in the event log to
determine why this problem occurs.  I have uninstalled Mozilla and installed
Mozilla a number of times without success.  I have rebooted my machine after
uninstalling Mozilla.  I do have Netscape 7.1 installed so I do have a browser
that I can use.

Prior to the reported problem I have been and continue to be plauged with
sporadic BSOD's.  This is the first time that I have actually seen this type of
problem.

THANX(MKD).


Reproducible: Always
Steps to Reproduce:
1. Run Mozilla 1.7.3 on a Windows XP.
2. XP machine BSOD's.
3. Attempt to launch Mozilla by double clicking the Mozilla icon.

Actual Results:  
Nothing happens.  No browser window and no error message or pop-up.


Expected Results:  
The Mozilla web browser should have been launched.

After un-installing Mozilla I reinstalled Mozilla 1.7.3.  I will provide you
with the contents of the install_status.txt file:

Start Log: 10/4/2004 - 3:19:27 AM
    System Info:
        OS Type: NT51
        Major Version: 5
        Minor Version: 1
        Build Number: 2600
        Extra String: 
        Total Physical Memory: 523568KB
        Total Available Physical Memory: 111628KB

    Product Info:
        Install mode: Normal
        Company name: mozilla.org
        Product name (external): Mozilla
        Product name (internal): Mozilla
        Uninstall Filename: MozillaUninstall.exe
        UserAgent: 1.7.3 (en)
        Alternate search path: 

    Components corrupted (startup):
        none

    Destination Path:
        Main: C:\Program Files\mozilla.org\Mozilla
        SubPath: 

    Setup Type: C&ustom

    Components selected:
        Mozilla XPCOM
        GRE
        Navigator
        Mail & Newsgroups
        Spellchecker
        mozilla.org Uninstaller
        Chatzilla
        Debugger
        US English profile defaults
        English (US) language pack
        US region pack
        Inspector
        Quality Feedback Agent

    Components to download:
        Mozilla XPCOM found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        GRE found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        Navigator found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        Mail & Newsgroups found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        Spellchecker found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        mozilla.org Uninstaller found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        Chatzilla found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        Debugger found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        US English profile defaults found:
C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        English (US) language pack found:
C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        US region pack found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        Inspector found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        Quality Feedback Agent found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ns_temp\
        **
        ** All components have been found locally.  No components will be
downloaded.
        **

    Disk Space Info:
             Path: C:\
         Required: 66921KB
        Available: 18898760KB

    Download protocol: HTTP

    Download status: ok
        Mozilla XPCOM: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        GRE: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Navigator: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Mail & Newsgroups: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Spellchecker: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        mozilla.org Uninstaller: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Chatzilla: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Debugger: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        US English profile defaults: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        English (US) language pack: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        US region pack: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Inspector: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Quality Feedback Agent: NetRetries:0, CRCRetries:0, NetTimeOuts:0

    Turbo Mode: true

    uncompressing GRE: 0
    launching GRE

    Uncompressing Xpcom Succeeded: 0

    XPInstall Start
        Navigator: 0 OK
        Mail & Newsgroups: 0 OK
        Spellchecker: 0 OK
        Chatzilla: 0 OK
        Debugger: 0 OK
        US English profile defaults: 0 OK
        English (US) language pack: 0 OK
        US region pack: 0 OK
        Inspector: 0 OK
        Quality Feedback Agent: 0 OK
    XPInstall End

    Launch Apps Start
    Launch Apps End
End Log: 10/4/2004 - 3:19:57 AM

Comment 1

14 years ago
Does a mozilla.exe show up in the taskmanager? Does anything happen when you 
launch Mozilla with mozilla.exe -profilemanager ?
(Reporter)

Comment 2

14 years ago
For this issue I was asked the following question:
Does a mozilla.exe show up in the taskmanager? Does anything happen 
when you launch Mozilla with mozilla.exe -profilemanager?

Answer: From the Command Prompt when I execute the command:

C:\>"C:\Program Files\mozilla.org\Mozilla\mozilla.exe"

or

C:\>"C:\Program Files\mozilla.org\Mozilla\mozilla.exe" -profilemanager

I checked the Windows Task Manager and do not see the program mozilla.exe
running.  I also checked to see if there was any information in the Event Viewer
and did not see anything that would indicate a failure in Mozilla to start.

Is it possible that there is some form of corruption in the Windows registry
that is causing this problem?  Can you tell me how I can check the Windows
registry for the Mozilla entry and what it should look like?  I am a UNIX
centric person and unfamiliar with Windows registry, etc.

Thank you for your assistance in this matter.  I do look forward to your reply.

THANX(MKD).

Comment 3

14 years ago
I have been having frequent BSOD's on my machine since reinstalling Windows XP 
several weeks ago -- on average one a day. This is the same hardware and 
software combinations I had been running (with the exception of XP SP2), but I 
downloaded and installed the latest firefox (install_status.log is below). I 
finally figured at that each time the system crashed with various STOP errors 
I was browsing in Firefox (I have a particular set of URLS that seem to do it 
every time). When sending the error report to Microsoft, it claims the error 
is caused by a driver (network driver is same as before reinstall, video 
driver has been updated since) but I can cause the BSOD with only Firefox 
running and broswing (http://www.skichalet.com/main/index.cfm).

This is probably not a ton to go on, but I've ruled out just about everything 
but Firefox. Switching back to IE leaves me with no trouble. I may revert to 
an older Firefox...

Start Log: 9/29/2004 - 12:57:08 AM
    System Info:
        OS Type: NT51
        Major Version: 5
        Minor Version: 1
        Build Number: 2600
        Extra String: Service Pack 2
        Total Physical Memory: 1048048KB
        Total Available Physical Memory: 827400KB

    Product Info:
        Install mode: Normal
        Company name: Mozilla
        Product name (external): Mozilla Firefox
        Product name (internal): Mozilla Firefox
        Uninstall Filename: UninstallFirefox.exe
        UserAgent: 1.0PR (en-US)
        Alternate search path: 

    Components corrupted (startup):
        none
H
    Destination Path:
        Main: C:\Program Files\Mozilla Firefox
        SubPath: 

    Setup Type: &Custom

    Components selected:
        Cross-Platform COM
        Firefox Browser
        Mozilla Uninstaller
        en-US Language Pack
        Firefox Help
        Quality Feedback Agent

    Components to download:
        Cross-Platform COM found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\7zS6.tmp\
        Firefox Browser found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\7zS6.tmp\
        Mozilla Uninstaller found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\7zS6.tmp\
        en-US Language Pack found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\7zS6.tmp\
        Firefox Help found: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\7zS6.tmp\
        Quality Feedback Agent found: C:\DOCUME~1\ADMINI~1\LOCALS~1
\Temp\7zS6.tmp\
        **
        ** All components have been found locally.  No components will be 
downloaded.
        **


    Uncompressing Xpcom Succeeded: 0

    XPInstall Start
        Cross-Platform COM: 0 OK
        Firefox Browser: 0 OK
        en-US Language Pack: 0 OK
        Firefox Help: 0 OK
        Quality Feedback Agent: 0 OK
    XPInstall End

    Launch Apps Start
    Launch Apps End
Product: Browser → Seamonkey
(Reporter)

Comment 4

14 years ago
I was able to resolve the reported problem by replacing the Windows registry
entries from another Windows XP machine that I was running with and had the same
version of Mozilla installed.  The entries that I replaced are:

Mozilla.reg, Mozilla_org.reg and MozillaPlugins.reg

I hope that the information in this bug report will help in understanding what
caused this problem.

This bug report can be closed.

THANX(MKD).
(Reporter)

Comment 5

14 years ago
I was able to resolve the reported problem by replacing the Windows registry
entries from another Windows XP machine that I was running with and had the same
version of Mozilla installed.  The entries that I replaced are:

Mozilla.reg, Mozilla_org.reg and MozillaPlugins.reg

I hope that the information in this bug report will help in understanding what
caused this problem.

This bug report can be closed.

THANX(MKD).
-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.