If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Profile stored in Users Application Data causes problems in Domains with small roaming profile sizes

VERIFIED DUPLICATE of bug 74085

Status

()

Firefox
Shell Integration
--
enhancement
VERIFIED DUPLICATE of bug 74085
13 years ago
13 years ago

People

(Reporter: Ben Langridge, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Firefox stores the users profile and web cache in the currently logged on user's
Application Data folder.  When roaming windows profiles are used in a Domain,
this can push the profile size above the maximum making it slow to log on to
machines and sometimes not allowing a log-off until the Firefox cache is cleared.
Just giving the option of defining where the profile is stored would resolve this. 

Reproducible: Always
Steps to Reproduce:
1. Install Firefox on a machine in a Domain using a roaming profile.
2. Browse a few sites until the Firefox cache is quite large.
3. Try logging off the box, or logging into another machine.

Actual Results:  
Can't log off on some domains as the windows profile size is too big.  Slow to
log on to other machines as the profile has to be copied across each time.

Expected Results:  
An ability to choose where the Firefox profile is stored.

This would help the roll out of Mozilla in large corporations (or universities
etc..) where roaming profiles are used.

Comment 1

13 years ago
You can define where a profile is stored with "firefox.exe -p" and make the
profile be where you want.

*** This bug has been marked as a duplicate of 74085 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
The easiest way to bypass this problem is to compile a batch script and replace
the firefox.exe with the batch script. If you require a compiled batch script
email me and I will send you an executable with the commands you want in the
batch script.

start firefox2.exe -Profile "%USERPROFILE%\Local Settings\Application
Data\Mozilla\Firefox\profiles\default.xxx" -url "%1"

Note: firefox2.exe is the orginal executable.

You will need to modify the registry in one location to specify an alternate
icon if Firefox is set as the default browser. This will be noticable because
the start menu will show Firefox with an inappropriate icon.

In addition you will need to create a shortcut for all users with the correct
icon on the desktop, startmenu and quicklaunch bar locations.

Finally you will probably want to set a userpref in the prefs.js to place the
bookmarks on the users home drive.  Since you can't use environmental variables
in the prefs.js file to specify the correct UNC path you will need to use a
mapped drive.

user_pref("browser.bookmarks.file", "H:\\TSProfile\\Application
Data\\Mozilla\\Firefox\\bookmarks.html");


 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.