Fonts options in pref UI, Outgoing Server in Account Settings are broken with a xul parsing error

VERIFIED FIXED

Status

--
blocker
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: fredbezies, Assigned: benjamin)

Tracking

({fixed-aviary1.0, regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041003 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041003 Firefox/0.10

Maybe it is related to bug 262701 or not ; seen on aviary branch.

When I go to tools / options / fonts, instead of getting font options, I get
this xul error :

XML Parsing Error: undefinded entity
Location: chrome://communicator/content/pref/pref-fonts.xul
Line Number 9, Column 20:

headertitle="&lHeader;">
-------------^

Reproducible: Always
Steps to Reproduce:
1.Grab sources and keep them up 
2.Build them
3.Launch Thunderbird and go to tools / options / fonts

Actual Results:  
XML parsing error described above

Expected Results:  
fonts options.

Code source used was up-to-date at 06:30 mozilla.org time.
also occurs in linux bits, and also an issue in the Account Settings | Outgoing
Server (SMTP) panel.
OS: Windows XP → All
QA Contact: trix
Summary: Fonts options in preference UI is broken with a xul parsing error → Fonts options in pref UI, Outgoing Server in Account Settings are broken with a xul parsing error
Flags: blocking-aviary1.0?

Comment 2

14 years ago
sending over to benjamin. Looks like more fall out from the locale re-org
Benjamin :).
Assignee: mscott → bsmedberg
Keywords: regression
(Assignee)

Comment 3

14 years ago
*** Bug 263011 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

14 years ago
Created attachment 161183 [details] [diff] [review]
package communicator subdirs

This was simply forgetting to package the subdirs of communicator, due to the
strangeness of the repackaging system.
(Reporter)

Comment 5

14 years ago
Looks like repackaging is more weird than expected. Anyway, I found two more or
less annoying bugs ;)
(Assignee)

Comment 6

14 years ago
Attached patch landed on branch
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Flags: blocking-aviary1.0?
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
from bug 263011: Options/Prefs | Advanced | Saved Passwords | View Saved
Passwords is also affected.

Comment 8

14 years ago
Benjamin would your latest checkin have fixed the SMTP server panel in account
settings? It didn't look like it was using a communicator locale so it may be
from a different package.

it seemed to be complaining about missing this dtd file:

http://lxr.mozilla.org/seamonkey/source/mailnews/jar.mn#262

vrfy'd fixed with tbird 2004100606-0.8 bits on linux fc2.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.