Closed Bug 262956 Opened 20 years ago Closed 20 years ago

Context menu stays open on click+hold and release

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 101472

People

(Reporter: jgleigh, Unassigned)

Details

(Keywords: polish)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041004
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041004

A context menu that is opened with a click+hold should disappear if not item is
chosen and the button is released. This is how all other menu items work.

Reproducible: Always
Steps to Reproduce:
1. Right-click and hold to bring up context menu
2. Release mouse button

Actual Results:  
Context menu stays on screen until an item is chosen or a click elsewhere in the
page.

Expected Results:  
Context menu should stay open as long as the mouse button is held, but should
disappear if no option is chosen and the mouse button is released.
At first I thought this was not a bug, but then I tested it a bit more. Note
that quickly clicking the right mouse (correctly) leaves the context menu
displayed. However, in the Finder, after holding down the right mouse button for
approximately a second, the context menu will disappear onmouseup.

Notes:
 * this is not bug 95790
 * adding depedency to bug 34572: this seems specific enough not to be a dupe.
Status: UNCONFIRMED → NEW
Depends on: 34572
Ever confirmed: true
Keywords: polish
Is this a bug?
Try Ctrl+click on Safari. The behavior is same as Mozilla.
Ctrl+click+hold and then release. In Safari the menu disappears. In Mozilla it
stays there.
No longer depends on: 34572
see bug 101472 comment 5.

*** This bug has been marked as a duplicate of 101472 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.