Use of NS_OpenURI(nsIInputStream*,...) creates blocking stream.

VERIFIED DUPLICATE of bug 24624

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 24624
19 years ago
14 years ago

People

(Reporter: Judson Valeski, Assigned: Stuart Parmenter)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
http://lxr.mozilla.org/seamonkey/source/widget/src/gtk/nsSound.cpp#234 shows a 
line using the netUtil function that wraps an OpenInputStream() call. The result 
is that the user is handed an input stream to read data from. The 
inputStream->Read() call is a blocking call and can/will block the thread it's 
called on. If this steam is guaranteed to be read from a thread other than the 
UI thread, evaluate whether or not the blocking behavior is ok, and if so, close 
this bug. Otherwise, your code need to do an asynchronous load of the URI. If 
you don't want to implement nsIStreamListener, please look at 
nsIStreamLoader.idl which will call a callback function you implement when all 
the data has arrived (it does all the asyncronous work for you).
(Assignee)

Comment 3

19 years ago
*** Bug 24624 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Comment 4

19 years ago
dup

*** This bug has been marked as a duplicate of 24624 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.