Save as HTML only does not work (although the only option offered!)

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Thomas Wolff, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Save Page as -> Save as type:
the only option offered is "Web page - HTML only"

It's actually the option I wanted, but if I use it and save,
the (not displayed and not selectable) "complete" option is effective, 
storing embedded images in a sub-folder.

Reproducible: Always
Steps to Reproduce:
1. Save Page as
2. check Save as type selection box, only one option appears
3. Save
4. check saved files
Actual Results:  
other "Save as type" option was used

Expected Results:  
HTML only to be saved
(Reporter)

Comment 1

14 years ago
had searched bugs database for "HTML only"; 
some (2?) 0.8 bugs related to "Save as type" but nothing identical
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041005
Firefox/0.10

If I try to save this page I have 3 options:
web page, complete   ->saves as show_bug.cgi.htm (subfolder is created)
Web Page, HTML only  ->saves as show_bug.cgi.htm
text files           ->saves as show_bug.cgi.htm , should have been saveas .txt
                                  (most but not all tags were removed)

(Reporter)

Comment 3

14 years ago
(In reply to comment #2)

> If I try to save this page I have 3 options:
> ...
Well, I have only one option as described, also from this exact bug page.
So how can it be debugged? Can I provide any additional information?
I installed 1.0PR over 0.8, does that matter?
(In reply to comment #3)
> (In reply to comment #2)
> 
> > If I try to save this page I have 3 options:
> > ...
> Well, I have only one option as described, also from this exact bug page.
> So how can it be debugged? Can I provide any additional information?
> I installed 1.0PR over 0.8, does that matter?

Yes, bad business !!!!

But easy to solve
Close Firefox
Uninstall all extensions/themes
Uninstall FF 10.PR
Uninstall FF 0.8 (If that's still possible)
Make sure the program files/Mozilla Firefox/ directory is empty
Make a backup of /%appdata/mozilla/Firefox/ (profile)

Now reinstall FF1.0PR
See if that improves the situation ?


(Reporter)

Comment 5

14 years ago
OK, I found the bug to be caused by the extension 
"Download_Sort 2.0.3"

By the way [maybe this should be a separate bug report], as you 
suggested a complete re-install (which I did before trying the extensions):
How are we supposed to install extensions and themes from their 
downloaded copies?

With themes, it does not work at all.
With extensions, it does, but only after an additional step 
"Open with" xpi_auto_file and an annoying additional blank window opened;
moreover, when prompted for "Open with"..., why is 
"Do this automatically for files like this from now on." not selectable 
(as is often the case in many other situations)?
have a look if you can find a bug number before filing one.

->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.