When copying a .gif image from inside firefox, the pasted image is completely black.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Kilian Valkhof, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

When copying a .gif image from inside firefox into another program, the pasted
image is completely black, instead of the gif-image. the same problem does not
occur when trying to do this from IE

Reproducible: Always
Steps to Reproduce:
1.open a .gif file from a webpage, copy it using right mouse button and
selecting copy image, and paste it into any other program capable of handling
.gif's (word, paint shop pro)

Actual Results:  
the pasted image will be completely black.

Expected Results:  
it should have copied the image normally.
WFM: works for me

Image: http://stat.livejournal.com/img/btn_del.gif

Browser: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913
Firefox/0.10.1

Tested in several applications -- pasted OK.
(Reporter)

Comment 2

13 years ago
yeah, it does work with some .gif images, but if you look at the gif images used
at that site (www.nuclearweaponarchive.org) it becomes a black image.
This is because the image is optimised , with save and open in an application
you can view it
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.