Import from Outlook Express freezes Thunderbird

RESOLVED WORKSFORME

Status

MailNews Core
Import
--
critical
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Steve Yost, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10

When trying to import my email from Outlook Express (fresh setup, deleted entire
installation directory beforehand), the instant I click the Next button on the
import page (after selecting the Mail radio button), Firebird freezes. The next
button never even "pops back up". I have to kill the entire app.

Possible variant that might cause the problem: My email folders are installed in
a non-default directory. They're not under Win98\Application Data\Microsoft\...,
they're on a separate drive. Of course Outlook Express knows where they are, so
the location value is in the registry, I assume.

Also (I'll file a separate bug, but it might be related) the import of my
Address book (3000+ entries) took about two hours and froze at the end of the
process, but was apparently successful.

I'm on a Win98 Dell Inspiron 7000 laptop, 300-some MHz, 128M memory.

This all worked fine on a Windows 2000 box (though import of addresses was also
very slow there).

Reproducible: Always
Steps to Reproduce:
1. Select Tools->Import
2. Select Mail
3. Click Next

Actual Results:  
Thunderbird froze completely.

Expected Results:  
Imported all my email from Outlook Express.
(Reporter)

Comment 1

14 years ago
I just discovered that the exact same problem occurs with Mozilla 1.5 on the
same machine. (I had never used Mozilla for email before, and was hoping I could
import into Mozilla mail, then to Firefox).

Also, in the original bug report, I said "the next button never pops up". I
meant the 'Next' button on the dialog never repaints itself as undepressed.
(Reporter)

Comment 2

14 years ago
The problem doesn't seem to be (solely at least) caused by the fact that my OE
email isn't in the default location, because today on my Win2K machine (where
import worked successfully) I moved my OE mailbox to another folder (same drive
though) and tried the import into T-bird again, and it worked fine.
(Reporter)

Comment 3

14 years ago
New data suggests the problem might have to do with OE files being on another
drive: someone on the webmasterworld.com forums just mentioned the following to me:

I wrote to him:
<<<<<<<<<<<<<<<
[http://www.webmasterworld.com/forum21/8190.htm (#8) saying you had total
failure importing from OE to Thunderbird. For me Thunderbird 0.8 totally freezes
the instant I click the Next button in the import dialog. I filed a bug on this.
The thing is this works fine for me in Win2000, but fails on Win98. The only
unusual thing about my setup is that I don't have my OE email folders in the
default location -- they're on a separate drive. What's your setup like? I'm
wondering if we can help isolate the bug.
<<<<<<<<<<<<<<<<

He responded (my ***s for emphasis):
------------------------------------
Same setup as you more or less, but W2K, I just tried it with thunderbird .8,
the version I'd tried it on was .7. Setup:

W2K, service pack 4
***outlook express emails stored on different partition***
325 Megabytes of emails, many with attachments
Emails arranged with many subfolders, received and sent all arranged in
subfolders, with sub-sub-sub folders, I think 3 levels is as far as I go.

Results:
address book import appears to be working, just imported address book from OE.

Setting import worked

First attempt to import emails: nothing happens at all, just says, failed to
create folder for imported emails.

Second attempt: emails start importing, running now. Import successful. Small
glitch, emails with attachments are not marked as having attachments in tbird
but when I open them they have the attachments. Not a show stopper, but not good
either, it's important to be able to spot attachment emails. Might be a setting,
I'll see. 

Comment 4

13 years ago
Not a TB auto-migration bug -> Core:MailNews:Import
Assignee: mscott → nobody
Component: Migration → MailNews: Import
Product: Thunderbird → Core
Version: unspecified → Trunk

Comment 5

13 years ago
This still happens with the 1.1-alpha-build version 1.0+ (20050531) and Outlook
2003 under Windows XP (SP1, company-restriction).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

10 years ago
Gregor do you still see this?
QA Contact: import
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 7

10 years ago
This bug still happens with TB 3.0b1pre.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080810031125 Shredder/3.0b1pre

Comment 8

9 years ago
reporter's issue sounds => WFM per comment 3.  no test data, no response from Gregor, and IU's bug 455229 is FIXED.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.