Option to hide empty folders, including drafts, sent, junk, trash.

RESOLVED WONTFIX

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED WONTFIX
14 years ago
8 years ago

People

(Reporter: rfb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [driver: WONTFIX?])

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I would like a configuration option to hide empty folders (possibly need to
doubleclick the parent folder to then see all the children that were hidden). 
Implemented, I expect that it would work similar to the microsoft method of
hiding unused menu items unless you click a special lower bar.  If I clicked an
account twisty, it should open and show folders with messages (and their counts,
sizes) and have an extra thing to click if there are hidden ones.

This would help in the problems requiring the enhancement request for showing
message counts on closed/rolled up account labels, since it would reduce the
space than an account uses so more accounts can be displayed at one time.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 2

13 years ago
This is a feature, please vote for it.

Comment 3

12 years ago
For users with many accounts/folders and small screens this would be a great way to save space. I use 5 accounts, but I only use Drafts,Templates in the Local Folders account, so if the Drafts and Templates items were hidden in the other 4 accounts, I could save the space of 4x2 rows in the folder list.
It would already be great if all the special folders are treated similar to the Junk folder: created only when selected for their specific use in the settings.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
I still have 15 emails to contend with.  As my original request tried to say, is if there are entries in a folder lower than the one displayed, then pop its counts up to the highest display level (especially if all are closed to one line) so its easy to see which ones require opening and those that do not.  Once opened, then I would see counts on folders that either had the messages or are a level up from those that have messages.

With a 19" Flat panel, I don't have the resolution to see all those inboxes at one time.
 

Updated

11 years ago
Duplicate of this bug: 370762

Comment 6

11 years ago
For TB 2.0, it is possible to remove Drafts, Sent and Templates folders for individual accounts, but at least one folder of each type must continue to exist.  See bug 197228.

Every identity (one or more per account) points to a folder for each of these functions, and if that folder doesn't exist, it will be created at startup.

With current builds, you would (e.g.) change each identity to point to 
Local Folders/Templates  for its template directory.  Once this has been done, you can then delete the individual Templates directories in each account.

Also, if Junk controls are turned off for each account, the junk folder can be removed as well.


Also, for 2.0, there are Folder Views -- the Folder pane can be set to show the entire tree, or Recent, Favorite or Unread folders.
QA Contact: front-end

Updated

10 years ago
Assignee: mscott → nobody

Updated

9 years ago
Component: Mail Window Front End → Folder and Message Lists
QA Contact: front-end → folders-message-lists
Whiteboard: [driver: WONTFIX?]

Comment 7

8 years ago
Yeah there are other existing ways (or ways it should be implemented) to get what you want. What you propose sounds like it would require quite a lot of ui in the end.

->WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.