firefox dies, restarts, dies, restarts, dies, restarts




Startup and Profile System
14 years ago
10 years ago


(Reporter:, Assigned: Benjamin Smedberg)


Firefox Tracking Flags

(Not tracked)




14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5 (KHTML, like Gecko) Safari/125.9
Build Identifier: 

sorry if this is a dupe, since i know i submitted this once previously; it's no longer listed amongst "my 
bugs", and i don't find a similar bug still listed, even closed.

when starting firefox on my titanium, the icon bounces in the dock a couple of times, then stops, then 
bounces a couple of times, then stops, ad infinitum.  the only way to stop this endless loop is to open , find the pid, and kill it quick before it spawns a new one.

using version 0.8 (20040206) does not cause a problem.  i have version 0.10.1 installed on my iBook 
G3, and it does not exhibit this behavior.

i've previously tried entirely expunging every bookmark or any other personal thing associated with 
firefox, without success.  this has been a problem since around build 0.9, still existed with 0.9.3 and 
still exists with 0.10.1 .

Reproducible: Always
Steps to Reproduce:
1. install firefox 0.10.1 (or 0.9.3 or 0.9)
2. double-click dock-icon or package in Applications folder

Actual Results:  
firefox dock icon bounces, then stops, then bounces, then stops, ad infinitum.  new processes get 
repeatedly spawned as shown in and can only be killed with kill -9 if done quickly.

Expected Results:  
started firefox

sorry, it leaves no stack traces o other information.  i will work with anyone to solve this problem.

Comment 1

14 years ago
I'm pretty sure this is a duplicate but can't find the other one right now.
I have never had this problem since Firefox 0.8. Did you try it on a new profile?

Comment 2

14 years ago
re-doing it again seems to have made the problem go away.  (i had tried removing
everything in my /Users/user/Library/ folder that looked like it had anything to
do with firefox, including the Mozilla/ & Phoenix/ subfolders, but i guess they
re-appeared when i re-installed the 0.8 versions for my last test.)

at the very least, perhaps this bug can be left in place, even if it is resolved
as fixed, so anyone running into this problem knows deleting those folders and
installing version 0.10.1 or later seems to solve the problem.

marking as resolved-fixed.
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 3

14 years ago
FIXED is the wrong resolution...
Resolution: FIXED → ---

Comment 4

14 years ago
use WORKSFORME instead
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.