There is no download link at mozilla.org/products/firefox

RESOLVED WORKSFORME

Status

()

Firefox
Installer
--
major
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Michael R. Wolf, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

There is no easy way to download the product from the products' own page!!! 
This is a major usability snafu.  The only one I found was under "Other systems
and languages".  Never mind that this was the first in a list, so "other" made
no sense -- "DOWNLOAD NOW" should be easy to find.  Really easy.  Stupifyingly easy.

I hope I've made my point.  Please don't backlash against me -- backlash against
the problem.  Make it easy for folks to *start* using the product, or they will
never find out how easy the product is to use.  It's about the "out of the box"
experiences, as the Apple usability folks would say.

Reproducible: Always
Steps to Reproduce:
1. Navigate to http://www.mozilla.org/products/firefox/
2. Search for "download"
3. Notice that none of these are links.
4. Search around.
5. Become frustrated that all the hype has no easily findable links to a
download of the product.


Actual Results:  
Frustration, leading to loss of credibility in the otherwise well founded
marketing hype about a product that I'm actually interested in using, and have
started promoting.

Expected Results:  
Read the hype!

Decide to make the switch.

Hit the big "Download & Install" button.

Have it work.
(Reporter)

Comment 1

13 years ago
I tried a different route:

The Foxfire main page has a link "make the switch today" which leads to the
following text (on http://www.mozilla.org/products/firefox/switch.html), then
leads me to http://www.mozilla.org/products/firefox/ where there is no "Free
Download" button.


Getting Mozilla Firefox

   1. To download Firefox, go to getfirefox.com and select "Free Download"


There may be convoluted ways to get the product download, but if the obvious
ones are broken, how confident (or bullheaded) must I be to keep trying?
(Reporter)

Comment 2

13 years ago
And when I finally do get to the page
(http://www.mozilla.org/products/firefox/releases/0.10.html#download) that seems
to be able to do the downloading for me (surreptitiously hidden under "system
requirements"), the language and links looks more like I'm downloading the
windows installer than a product that will be installed by the windows installer.

Downloading Firefox

Mozilla Foundation provides Firefox binaries for Windows, Linux, and Mac OS X.

Windows: Installer

Linux: GTK2 + XFT installer

MacOS X: Compressed Disk Image


======

Overall impression of the install procedure -- inimpressive.  Even though I was
looking forward to the release, I'm gonna wait.  It's too hard.  And I've got 20
years' experience with Unix and Windoze.

Comment 3

13 years ago
There's a big green "Free Download" box at the top right of
http://www.mozilla.org/products/firefox/.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Summary: There is no download link at mozilla.org/products/foxfire → There is no download link at mozilla.org/products/firefox
(Though I'm mildly curious if this bug means it's of a size and structure that
makes it vulnerable to some ad-blocking or other...)

Comment 5

13 years ago
I agree with comment 2 about the release notes.  I filed bug 263118 to keep
separate issues in separate bugs.
(Reporter)

Comment 6

13 years ago
I do *not* see a big green button in any of these browsers on my W2K PC:
 - Firefox 0.9.3
 - IE 6.0.2800.1106

I *do* see the green "Free Download" and the blue "Or, get..." blocks on my
wife's XP PC
 - IE 6.0.280.1106.xpsp2.030422-1633
 - Firefox 0.9.3

Here's the behavior on my SuSE 9.1 box:
  - Default browser (Mozilla 1.6) -- a completely different looking page, that
offers to "Bookmark this page" with a URL starting at
http://landing.domainsponsor.com/ds/skins/skin3m.php?....


I've reopened this with the observation that the page is vulnerable to some (as
yet unknown) browser or system option, and may even be getting redirected for
some different browsers.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Clear your cache and try again

tried in 
Firefox1.0PR 
Opera 7.54
Mozilla1.7
K-Meleon
IE6

All show the link, so obviously if you don't see it it's something in you system 

->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.