bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Current popup blocker implementation is too invasive / Themes and extensions

RESOLVED INVALID

Status

()

Firefox
General
--
enhancement
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Jesse, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

In the current implementation of popup blocking, the information that the popup
has been blocked is displayed over the top of the current page as a yellow
margin, apparently taking up space that belongs to the page. This might not be
bad for everyone, but my preference is to have a small icon in the toolbar(?) at
the bottom of the window. It would be nice if this kind of option could be
modified as part of the browser "theme". Of course, since the specifics of the
functionality of the popup blocker would have to change as well, this option
would violate the rule that 'a theme can only control appearance, not
functionality.'. I'm no expert, but my guess is that the solution is to
implement the specifics of both appearance and function as user modifiable
scripts, with 'theming' broken down into specific user interface functions that
can arbitrarily hook into browser functions (e.g. buttons/icons could be added
at will into the UI (not via extensions) which could hook into any functions the
user wanted). Of course, this would break down the distinction between
appearance and function that allows 'themes' to be separate from 'extensions',
since every theme in place is designed for a specific set of functions, which
would of course be different from browser to browser (given extensions,
especially if extensions were made very easy for users to make/modify). This is
a fundamental problem. Is anyone working on ideas of new ways of working around
this problem? I would like the appearance of all functions, be they extensions
or not, to be under the complete control of the user, this includes the
appearance of the right-click context menu, etc. In any case, creating themes,
and to limited extent, new functionality (via extensions and whatnot), should be
part of the individual user experience. Because anything that might be
considered a "specific detail of implementation" should in principle be
accessible, and not 'hardcoded' into the browser or into extensions and themes,
which are not well documented and don't seem to have user modifiability as a
consideration in the implementation process.

Reproducible: Always
Steps to Reproduce:
1. open a page which has popups / interact with user interface
2.
3.

Actual Results:  
Loaded page was 'invaded' by popup blocker information

Expected Results:  
Used the user interface instead as the means of displaying the information.
Well, if you read the content of the "popup bar" .....
there's "Click here for options....."
click on it
Select "don't show this message when popups are blocked"
The next window tells you where the icon for blocked popups will be (statusbar)
press OK and you won't see that bar again.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

14 years ago
Ok, you're right. But that message is annoying and never appeared in previous
versions and never really became necessary. And it wasn't clear to me that
clicking "don't show this info message when popups are blocked" would not just
silently block popups. I assumed that was it's purpose. And if it is going to be
a left click, and it says "click here", then "here" should be underlined or in
bold, just like a link, since it appears in page-space (and since the whole
thing is clickable, it ought to just say left-click for more options). And,
since it is a drop down menu, it ought to be a right click . In addition, you
are wrong about there being a message explaining where the blocked popup icon
will be, it never showed up, not that I think it is necessary.Also, is there a
way to control the layout of the statusbar? Like the location of the 
icons? Thanks. 

 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Not really a bug. Complaints about the UI are best handled in discussion groups,
bugzilla is a poor mechanism for hashing out that kind of thing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.