No way to select mail "helper app" in Firefox if using KDE instead of Gnome

RESOLVED WONTFIX

Status

()

Firefox
Preferences
RESOLVED WONTFIX
14 years ago
12 years ago

People

(Reporter: Trevor Smith, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

I use KDE 3.3.0-2.2.2.kde and wanted to use KMail as my application for handling
mailto: tags. There appears to be no way to set this in Firefox
(Edit->Preferences no longer handles this in Firefox). But Firefox ignores my
system default settings in KDE to have KMail as my default mail program and
insists on opening Evolution.

I was required to leave KDE and log into Gnome to set a system wide 'mailto:'
handling request for KMail instead of Evolution.

Firefox should look for KDE's setting of this item, not insist on using Gnome's
settings (since I never use Gnome).

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
At present, this is a WONTFIX.  We're not going to implement arbitrary UI for
mailto handling, any sane OS has a service to handle various protocols.  We're
using the GNOME shellservice at present, just like we're moving to GTK
filepickers etc.  This is, of course, because we're a GTK, not a qt, app.

If the qt port spawns a Firefox port for KDE, then someone can write a KDE
shellservice for that port and use the KDE system default.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.