Closed Bug 263205 Opened 18 years ago Closed 18 years ago

Download Manager pegs 1Ghz CPU at 90% for 45 seconds to download a file

Categories

(Toolkit :: Downloads API, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 161783

People

(Reporter: eric.r.johnson, Assigned: bugs)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Running Firefox 0.10.1 on a PowerBook G4 w/1 Ghz CPU & 1GB RAM.  Mac OS X
10.3.5, Java 1.4.2 update 2.

When I download a large file (like a 3 MB PDF), it takes a long time for the
download manager to start and execute the task.  During this time, the system
CPU goes to 90% and remains there until the download is complete and the
download manager quits.

If this is expected startup overhead for invoking a download manager that hasn't
been instantiated, I'd suggest offering the user the option of instantiating the
download manager on Firefox startup and not each time the user downloads a file.

Reproducible: Always
Steps to Reproduce:
1.  Download any large file using the above setup.
2.
3.

Actual Results:  
System CPU goes to 90% while the download manager is running.

Expected Results:  
Consume a reasonable amount of CPU
Seems to show the JVM getting instantiated.  If so, this is alot of overhead to
go through each time a user needs to download something.

*** This bug has been marked as a duplicate of 161783 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
This does not seem like a dupe of that bug at all.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.