select box goes off top of screen on laptop display when using dual monitors

RESOLVED DUPLICATE of bug 248552

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 248552
14 years ago
11 years ago

People

(Reporter: Kevin Hanser, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When I have an external monitor hooked to my laptop, and I am running the laptop
LCD as the secondary monitor, if I have a select box near the top of a page,
when I click it, the selections go off the top of the LCD display and I cannot
see all of them.

I run different resolutions on each display, 1280x1024 on the primary/external
monitor, and 1024x768 on the laptop LCD.  I assume that firefox is probably
getting confused and reading the wrong resolutions or something...

Reproducible: Always
Steps to Reproduce:
1. open firefox
2. move firefox window to secondary (laptop LCD) display
3. maximize firefox
4. find a web page that has a select box near the top of the page
5. click the select box, and the selections go up instead of down, and it ends
up going off the top of the display

Actual Results:  
the selections went off the top of the screen :)

Expected Results:  
put the select dropdown in some place that I could see/click on all the choices

If you want a screenshot or anything, feel free to email me for more info and I
will provide whatever additional information I can.  I would give you a URL to
test it out on, but the only place I've seen it so far is on a web app that I'm
devoloping currently that doesn't have external access....  (normally I run
firefox on my main monitor, but when I'm developing, I code on the main monitor
and test via firefox on the secondary..)

Updated

14 years ago
Keywords: testcase

Updated

14 years ago
Keywords: testcase
(Reporter)

Comment 1

14 years ago
Created attachment 161373 [details]
screenshot of problem

screenshot of select box going off top of screen, notice that there's no top
arrow on the scrollbar, and no way to get to the topmost selections...
(Reporter)

Comment 2

14 years ago
Created attachment 161374 [details]
screenshot of select off top of screen in IMP (webmail application)

seconds screenshot of select box going off top of screen.  this is from the IMP
webmail application (www.horde.org).

Comment 3

14 years ago
I have the same problem with Firefox 1.0PR, running two monitors on my windows
xp desktop machine, monitor 1 @ 1280x1024 and monitor 2 @ 1024x768.

A good test is to run phpmyadmin fullscreen on the smaller res monitor, most of
the select boxes extend off the top of the screen.

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 248552 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.