border=0(px) not interpreted in CSS for IMG element

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: rc, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

To avoid a blue frame around an image that has a link destination you type normally:
<a href="http://www.domain.com"><img src="" BORDER=0></a>
To do this not every time you have an image on the page CCS can solve this:
img { border:0px }
img { border:0 } for IE

FireFox does not interpret one of these commands.
My life would be better if it does ;-))

Rüdiger

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041007
Firefox/0.10

<style type="text/css">
 img{border:0}
</style>

border:1 is ON 
border:0 is OFF 
 these aren't pixels

WFM
WFM as well, with both the "0" and the "0px" versions. 
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041006
Firefox/0.10

Reporter - can you please attach a testcase where this doesn't work for you?
From the reporter via e-mail:

> I am sorry.
> I wrote
> img {border=0}
> instead with ":"
> Two different syntaxes killed me ;-)

Marking WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
--> Websites :: www.mozilla.com so timeless can close out Firefox :: Product Site.
Component: Product Site → www.mozilla.com
Product: Firefox → Websites
QA Contact: www-mozilla-com
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.