Quality feedback agent doesn't support proxy authentication

VERIFIED DUPLICATE of bug 36545

Status

Thunderbird
General
--
enhancement
VERIFIED DUPLICATE of bug 36545
14 years ago
14 years ago

People

(Reporter: Gert-Jan Vons, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041005 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041005 Firefox/0.10

Whenever thunderbird (or firefox) crashes, the quality feedback agent starts,
but fails to upload the problem to the server on the internet.

This is due to my company's internet proxy requiring authentication, which the
quality feedback agent doesn't support: it allows me to specify the proxy but
not the user name and password to use.

Consequently, this talkback tool doesn't work for me, and the only thing I can
do is delete the reports it generates.


Reproducible: Always
Steps to Reproduce:
1. find a proxy that requires authentication
2. tell the quality feedback agent to talk to it
3. have firefox/thunderbird/... crash

Actual Results:  
the QFA displays an error message stating it is unable to connect

Expected Results:  
ask me for a proxy user name and password before it tries to upload the error report

Comment 1

14 years ago
I had this same problem in Firefox 1.0PR. It appears to be a duplicate of Bug
36545, which states that there is no fix because Talkback (which is used for the
Quality Feedback Agent) does not support proxy authentication.

There is a workaround mentioned in the comments, however, which is to use a
program called Proxomitron (http://www.proxomitron.org/). Apparently Proxomitron
will set up a proxy (that does not require authentication) to interface with the
actual proxy (that does require authentication). Note that this program is no
longer supported but appears to still be available.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 36545 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Severity: normal → enhancement
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.