mouse wheel doesn't scroll in many places (OS X)

RESOLVED DUPLICATE of bug 236909

Status

()

RESOLVED DUPLICATE of bug 236909
14 years ago
14 years ago

People

(Reporter: mtb19, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

There are many places where the mouse wheel is useless (at least on OS X). Here
are a few:

+- The expanded "Add Bookmark" dialog
+- The JavaScript console when a message is not selected
`- Every preference panel I've tested
   +- Downloads -> File Types
   +- Advanced (if all the items are expanded)
   +- Privacy (if items are expanded)
   +- Privacy -> Cookies -> View Cookies
   `- Privacy -> Saved Passwords -> View Saved Passwords

Reproducible: Always
Steps to Reproduce:
1. Surf around so you have a bunch of cookies.
2. Open the preferences window.
3. Go to Privacy -> Cookies -> View Cookies.
4. Try to scroll the list using the mouse wheel (note: you need a sufficient
number of cookies to make sure the list is long enough so that it may be scrolled).

Actual Results:  
The list does not scroll.

Expected Results:  
The list should scroll.

This is especially annoying in some of these cases because the viewable portion
of the window/list is so small. In these cases, the mouse wheel is one of the
more efficient methods of navigation, since clicking the arrows is cumbersome,
and the scroll bar is so small that moving the grabber skips too many items.

In the cases I've tested, the arrows and page up/down still work, so there is an
alternative, but it's frustrating because both are right-handed operations, so
one has to keep moving one's hand back and forth between the mouse and the keyboard.

Comment 1

14 years ago
(In reply to comment #0)
> +- The expanded "Add Bookmark" dialog
see bug236909 . 

> +- The JavaScript console when a message is not selected
The same is said of the Windows version.

> `- Every preference panel I've tested
>    +- Downloads -> File Types
The Windows version works.

>    +- Advanced (if all the items are expanded)
>    +- Privacy (if items are expanded)
The same is said of the Windows version.
But It will work, if a focus is moved.


>    +- Privacy -> Cookies -> View Cookies
>    `- Privacy -> Saved Passwords -> View Saved Passwords
The Windows version works.

Windows XP Pro SP1
Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.7.3) Gecko/20041007
Firefox/0.10
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> (In reply to comment #0)
> > `- Every preference panel I've tested
> >    +- Downloads -> File Types
> The Windows version works.
> 
> >    +- Advanced (if all the items are expanded)
> >    +- Privacy (if items are expanded)
> The same is said of the Windows version.
> But It will work, if a focus is moved.
> 
> >    +- Privacy -> Cookies -> View Cookies
> >    `- Privacy -> Saved Passwords -> View Saved Passwords
> The Windows version works.

I went back to these to make that I wasn't missing something with the focus
behavior, but I wasn't: on OS X, the mouse wheel just plain doesn't work in
these contexts, regardless of focus.

Comment 3

14 years ago
I second the report.  All prefs panels cited in the original report do not
scroll with the wheel.  FF 0.10.1, 20040913 (same as original report).  It's
actually a bit annoying. :(

Comment 4

14 years ago


*** This bug has been marked as a duplicate of 236909 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.