improve explanation of 'proxy'

RESOLVED FIXED in Firefox1.0

Status

--
enhancement
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: bugzilla.fr, Assigned: steffen.wilberg)

Tracking

({fixed-aviary1.0, late-l10n})

unspecified
Firefox1.0
fixed-aviary1.0, late-l10n

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.3) Gecko/20040922 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.3) Gecko/20040922 Firefox/0.10.1

See prefs.xhtml  : 

http://lxr.mozilla.org/seamonkey/source/browser/components/help/locale/en-US/prefs.xhtml#148


148     <p>Many organizations block access from the Internet to their networks.
149       This prevents outside parties from gaining access to sensitive
150       information. The protection is called a firewall.</p>
151     <p>If your organization has a firewall, the browser may need to go through
152       a proxy server before connecting you to the Internet. The proxy server
153       prevents outsiders from breaking into your organization's private
154       network.</p>


The text should be : 
152       a proxy server before connecting you to the Internet. The proxy server
153       permit to go through the firewall witch prevents outsiders from
breaking into your organization's private
154       network.</p>



Reproducible: Always
Steps to Reproduce:
(Assignee)

Comment 1

14 years ago
I don't understand why we mention "firewall" here at all. Firewalls and proxys
can be used independently. For example, some ISPs force their customers to use a
proxy of the ISP. This has nothing to do with a firewall.

See http://en.wikipedia.org/wiki/Proxy_server
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
Bug 253104 ([TRACKER] Firefox Help Documentation changes before the 1.0 release)
should depend on this one.
Ph
Blocks: 253104
(In reply to comment #1)
> I don't understand why we mention "firewall" here at all. Firewalls and proxys
> can be used independently. For example, some ISPs force their customers to use a
> proxy of the ISP. This has nothing to do with a firewall.
> 
> See http://en.wikipedia.org/wiki/Proxy_server

Steffen, you take care of this one.  You've got a better understanding of the
terms than I do, it seems.
Assignee: jwalden+fxhelp → steffen.wilberg
(Assignee)

Updated

14 years ago
Keywords: late-l10n
(Assignee)

Comment 4

14 years ago
Created attachment 161912 [details] [diff] [review]
patch

This is not strictly necessary for 1.0, but I think it's more accurate.
(Assignee)

Updated

14 years ago
Attachment #161912 - Flags: review?(jwalden+fxhelp)
Comment on attachment 161912 [details] [diff] [review]
patch

>+    <p>Your organization or internet service provider may offer or require you
>+      to use a proxy. A proxy acts as an intermediary between your computer and
>+      the Internet. It intercepts all requests to the Internet to see if it can
>+      fulfill the request itself, using its cache. Proxies are used to improve
>+      performance, filter requests, and hide your computer from the Internet to
>+      improve security. They're often part of a corporate firewall.</p>

Remove "itself, " from the third sentence (the comma's not necessary, and the
"it"ses pile up in this sentence) and change "They're" to "Proxies are" in the
last sentence ("They're" is somewhat unclear due to its distance from
"Proxies") and r=me.

Must remember: always update date in changed files!
Attachment #161912 - Flags: review?(jwalden+fxhelp) → review+
(Assignee)

Comment 6

14 years ago
Checked in br & trunk.
Severity: normal → enhancement
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
Summary: Explanation of proxy in help : prefs.xtml is not good → improve explanation of 'proxy'
Target Milestone: --- → Firefox1.0

Comment 7

10 years ago
Steffen: which version was this fixed in?
(Assignee)

Comment 9

10 years ago
If you ask which version of Firefox this was fixed in, see the target milestone ans keywords: Firefox 1.0.

Comment 10

10 years ago
Oh. Sorry, I looked at the wrong field (version). I was asking b/c I was working on updating the proxy documentation, and I am trying to figure out what products to revise. My thinking is to do FF3-only, for now, b/c the content is in MDC.
(Assignee)

Comment 11

10 years ago
Sure, don't bother with Firefox 2 anymore.
Also check out the knowledge base on http://support.mozilla.com/, which replaced the in-product help pages (menu Help -> Help Contents).
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.