"crash" when trying to scroll down in js console

RESOLVED WORKSFORME

Status

Core Graveyard
Error Console
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: Jonathan Baron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
I think 3 times this has happened.  I open the javascript console.
I try to scroll down with the down arrow.  That doesn't work.  So
I try to use the scroll bar on the right, with the mouse.  What
happens is that my X server is killed, as if I had hit ctrl-alt-F1.
But it is much worse.  When I restart or reboot after this, it
takes 15 minutes to log in, and an hour to get the gnome panel.
This symptom went away in a few days, but it is back now.  I am
reluctant to do further tests of this bug!  (But I will if
necessary.  I have another computer I can use.)

I'm using Fedora Core 2.

This may be related to bug 112587, but I didn't think it was the
same.

Comment 1

13 years ago
The "crash" you're seeing is X dying it's not Mozilla's fault.  You should
report it to redhat/fedora (https://bugzilla.redhat.com/bugzilla/).  Can you
give more specific steps to reproduce the JS Console problem (before X dies)?

Perhaps more importantly, what build are you using?
(Reporter)

Comment 2

13 years ago
I agree that the crash is not Mozilla's problem.  In fact, I have now
upgraded to development versions of gdm, etc., and, while I still get
the crash, it does no long-term damage and I can just log in again.
But Mozilla is CAUSING this problem.

Although I have had this problem for some time, through several nightly
builds, the current build is 2004100605, and I just had the courage to
try again and got the problem again.  Unlike previous builds, this one
DOES allow the use of the arrow and PgDn keys in the JavaScript console,
and I was able to page down a couple of times before the crash happened
again.

So I think the problem is the result of scrolling down, no matter how
I do it.  It is not specific to the mouse.

I can easily avoid this by simply clearing the console before using it
to test my own pages.  The problem happens after browsing, say, the NY
Times, which is full of JavaScript errors and warnings, and then going
directly to my own test page, which usually has at most a couple of errors.
I have to scroll down to the end to see the part I want to see.
But I do think this should not be necessary, and it has been a consistent
problem.

Comment 3

13 years ago
what theme are you using?
(Reporter)

Comment 4

13 years ago
Interesting question.  I just got a chance to try it.  With the latest
build (2004101106) I get the crash with the Modern theme but not with
the Classic theme!  How did you ever know that this would matter?

Comment 5

13 years ago
I was actually hoping that you'd say you were using a 3rd part theme, but the
theme specificity is still interesting.

Have you filed a bug with redhat?
Are you using an XFT build? (see about:buildconfig)
(Reporter)

Comment 6

13 years ago
I was not using an xft build, but the last RPM from Fedora is an xft
build (1.7.3-0.2.0) and that does NOT show the problem (but it also
does not allow scrolling with the arrow keys in the JS console).

However, I just tried to replicate the problem with the very latest
build, and the problem seems to be fixed, perhaps as a side effect of
some other change (2004101306); again, this is not an xft build.
Moreover, the arrow keys work.

(By the way, if you want to test this quickly, go to www.nytimes.com
and read a couple of articles.  The console quickly fills up with
error messages, enough so that they do not fit in the largest possible
window.)

I will try a few more builds, but if nobody else reports this, I will
eventually try to change it to FIXED.  (Not sure I have permission to
do that, but I'll try, if it indeed stays fixed.)

I did not yet file a bug with RedHat, and now I probably won't.  The
newest version of Gnome did "zap" but without lousing anything up.
It isn't clear where that bug was (gnome or xorg).

Comment 7

13 years ago
> eventually try to change it to FIXED.

Actually, "FIXED" is reserved for bugs fixed by specific patches.  "WORKSFORME"
would be more appropriate for this bug.

see also https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121403, which
matches some of the conditions to crash X, but not all (unless there's binary
garbage at NY Times or in your JS Console.
(Reporter)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey

Updated

8 years ago
Component: Error Console → Error Console
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.