brand.dtd and brand.properties not getting set up right on the trunk

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: mscott, Assigned: benjamin)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Trunk only. Branch seems to be ok. We are using the generic brand.dtd file
instead of the one that contains the Thunderbird information.

To see this, go to Help / About and notice that the UI is "Application" instead
of "Thunderbird".

When I look inside en-US.jar, I see that two copies of brand.dtd and
brand.properties are getting added:

one under:
locale\en-US\global\
and one under
locale\global

The one under en-US is the generic one built from toolkit:
http://lxr.mozilla.org/mozilla/source/toolkit/locale/brand.dtd

the one under locale\global is the Thunderbird branded one. The app ends up
finding the one under en-US.
(Reporter)

Comment 1

14 years ago
just a reminder this problem is trunk only.

Branch seems to be working fine.
Keywords: regression
(Assignee)

Comment 2

14 years ago
-+ locale/global/brand.properties           
(@AB_CD@/chrome/global/brand.properties)
-* locale/global/brand.dtd                   (@AB_CD@/chrome/global/brand.dtd)
++ locale/@AB_CD@/global/brand.properties           
(@AB_CD@/chrome/global/brand.properties)
+* locale/@AB_CD@/global/brand.dtd                  
(@AB_CD@/chrome/global/brand.dtd)
(Assignee)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.