factcheck.org -- pages being served as application/octet-stream

RESOLVED FIXED in Nov

Status

P1
major
RESOLVED FIXED
14 years ago
4 years ago

People

(Reporter: jordan, Assigned: bugzilla)

Tracking

unspecified

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

When attempting to view the website FactCheck.org when using FireFox PR1,
clicking any link on the main page results in the file handler dialog being
displayed. You are then requested to either download the file or identify an
application with which to open it.

Reproducible: Always
Steps to Reproduce:
1. Go to FactCheck.org
2. Click on any link
3. You will see the file handler dialog

Actual Results:  
The file handler dialog is displayed.

Expected Results:  
Display the appropriate page, as is done by IE, Safari on Mac OS X, and IE on
Mac OS X.
(Assignee)

Comment 1

14 years ago
http://www.factcheck.org/article.aspx@docID=272

HEAD /article.aspx@docID=272 HTTP/1.1
Host: www.factcheck.org
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5)
Gecko/20041006 Firefox/0.9.1+
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Pragma: no-cache
Cache-Control: no-cache

HTTP/1.x 200 OK
Server: Microsoft-IIS/5.0
X-Powered-By: ASP.NET
Date: Thu, 07 Oct 2004 23:14:36 GMT
Content-Type: application/octet-stream
Accept-Ranges: bytes
Last-Modified: Thu, 07 Oct 2004 09:08:39 GMT
Etag: "d4af73c4dacc41:b0c"
Content-Length: 34898

By sending it as application/octet-stream, they're telling FF to offer a
download prompt for it.  This is a server problem, not a browser-problem.

->TE
Assignee: firefox → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P1
Product: Firefox → Tech Evangelism
QA Contact: firefox.general → english-us
Hardware: PC → All
Summary: FireFox PR1 incompatible with FactCheck.org → factcheck.org -- pages being served as application/octet-stream
(Assignee)

Comment 2

14 years ago
*** Bug 263414 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

14 years ago
Taking.  I sent a note tonight to the technical problems/webmaster contact
address to alert them to their problem.
Assignee: english-us → bugzilla
(Assignee)

Updated

14 years ago
Target Milestone: --- → Nov
(Assignee)

Comment 4

14 years ago
No reply from them, but links work for me now this morning.  It looks like
whatever system they use to generate their links was omitting a .html extension
on the end, as the links suddenly all have that this morning.

Resolving fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 263664 has been marked as a duplicate of this bug. ***
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.