Mailing lists mis-handle messages with URL as first line

RESOLVED FIXED

Status

P3
critical
RESOLVED FIXED
19 years ago
4 years ago

People

(Reporter: mpt, Unassigned)

Tracking

({dataloss})

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
When a message sent to one of the Mozilla.org mailing lists has an URL as its 
first line, Mozilla.org's mailing list software mistakes the URL for a message 
header -- adding its own headers after the URL, and separating the part after 
the colon from the rest of the URL by a space.

This renders the URL invisible unless the message is view-sourced, which 
creates quite a bit of confusion.

About to attach an example.
(Reporter)

Comment 1

19 years ago
Created attachment 4860 [details]
example of message mangled by mailing-list software

Comment 2

19 years ago
reassigning to risto
Assignee: mitchell → rko
I believe this bug is actually not in the mailing list software, but in either
the Collabra server itself or newsgate.

If it's in the Collabra server itself, I believe that Markus may have some plans
regarding the news server software that are relevant here.

If it's in the mail->news gateway, you can file a bug against me.  However, I
don't know when or if I'll ever make any more newsgate releases.  It may be
worth looking at possible newsgate replacement such as something based on Russ
Allbery's Perl code.

Comment 4

19 years ago
Haven't look into this but this just sounds like there's no two newlines between 
the message headers and body somewhere and the first line going to headers as 
http: header. I could be wrong though.
Status: NEW → ASSIGNED

Updated

18 years ago
Severity: normal → minor

Comment 5

18 years ago
Gee, can we fix this please? Right NOW?

Updated

18 years ago
Severity: minor → critical
Keywords: dataloss

Comment 6

18 years ago
Nope. Can't fix! 

I don't have time or any urge to go into Collabra code (inn-1.4 based) and fix
this.

Updated

18 years ago
Assignee: rko → nobody
Severity: critical → minor
Status: ASSIGNED → NEW

Comment 7

18 years ago
100% agreed with Markus. Moving to nobody.

Comment 8

18 years ago
-> Server ops, default owner.

It is data loss and appears in practice. Due to the nature of mailing-list
software, many people are hit from one occourance of the bug. No matter how you
fix this (fix the source or use other mailinglist software), this has to be
fixed.
Assignee: nobody → rko
Component: Miscellaneous → Server Operations
QA Contact: endico

Comment 9

18 years ago
default owner is rko, rko doesn't care, moving to endico, cc dmose.
Assignee: rko → endico
(Reporter)

Comment 10

18 years ago
I see this about twice a month on each of the Mozilla groups I am subscribed to. 
As Mozilla distributions are released, people will begin discussing on-line 
reviews of Mozilla (or its distributions) in the Mozilla groups a lot more often, 
so this bug will be encountered much more frequently.

Comment 11

18 years ago
If this were a simple issue, we'd have solved this long ago. First dmose filed a
bug against Collabra, but this got nowhere and there probably won't be another
release of Collabra (ever?). And a move away from Collabra is kinda tricky since
the current server handles all kind of shit (secure and/or password protected
discussions, beta stuff, etc.). To move away from this crap we have to split the
functionality and get news.mozilla.org moved onto new hardware (this part is
actually in the works now!).

Comment 12

18 years ago
Is there a bug about the mozilla.org hardware? Should this one depend on it? Any
ETA?

Comment 13

18 years ago
There is no bug on secnews hardware, since the hardware is not faulty. This is
just a project I've been trying to get done for years. To track it I don't need
no stinkin' bug ;-)
Status: NEW → ASSIGNED

Comment 14

18 years ago
Especially since secnews is NOT mozilla.org hardware nor is the new news 
architecture servers.

Comment 15

18 years ago
A bug is also useful for outsiders to track work.

Anyway, what is the ETA? This bug is filed since half a year, causes trouble
since nobody-knows-when and still does so, and nothing has been done so far.
(Reporter)

Comment 16

18 years ago
Created attachment 16983 [details]
Another example, this time with more than just an URL lost

Updated

18 years ago
Depends on: 74713

Comment 17

18 years ago
This is part of bigger project.
Assignee: endico → rko
Status: ASSIGNED → NEW

Comment 18

18 years ago
Pulling myself off from individual tickets.
Assignee: rko → mbaur

Comment 19

18 years ago
Collabra and SmartList are EOL'd.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
Wrong resolution.  This bug needs to remain open until a solution is installed
where this problem has been fixed.

In what way has SmartList been "EOLed"?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 21

18 years ago
The bug also showed up for smilies (no URL!) in msg
<news://news.mozilla.org/3B33605F.4090207@goldengate.net>. The gateway-generated
mail is X-Mailing-List: <mozilla-mail-news@mozilla.org> archive/latest/13511.

Comment 22

17 years ago
Moving tickets to Ray.
Assignee: mbaur → daruszka
Status: REOPENED → NEW

Comment 23

17 years ago
Mass changing IC's ticket to reflect current situation.

mozilla.org, AOL employees:

If you want IC to look at issues reported in bugzilla, please open a Helpdesk
ticket and ask it to be routed to AOL R1 Server Operations. We currently have no
way to handle comprehensive problem resolution through bugzilla. This is not a
change in the way we are supporting mozilla.org - we are still supporting you on
the level as before. IC's support is based on Helpdesk ticket system - not
bugzilla which only few hard-core people are looking at. 

Also, projects are handled elsewhere - not in bugzilla. If you have projects you
need us to deliver please feel free to contact me directly.

Summa summarum: tickets -> Helpdesk
Project initiations -> RKotalampi@aol.com

Assignee: daruszka → nobody

Comment 24

16 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: minor → critical
Blocks: 74713
No longer depends on: 74713
switching dependency back, this one was right before.
No longer blocks: 74713
Depends on: 74713
We're now using MailMan instead of slist.  I have a *really* hard time believing
that this bug would have survived the transistion. :)
Status: NEW → RESOLVED
Last Resolved: 18 years ago14 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.