When using "Same proxy for all protocols", it does not clone the port number with the IP.

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: djneoform, Assigned: mconnor)

Tracking

unspecified
Firefox1.5
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

If i enter an IP and port number the IP gets displayed accross all the other
protocols, but the port number does not.

Reproducible: Always
Steps to Reproduce:
1.Open connection settings
2.switch to "manual proxy configuration"
3.turn on "use same proxy for all protocols"
4.enter an ip and port.
5.save

Actual Results:  
the port number does not get copied accross the port fields.
(also, SOCKS does not clone the IP & Port)

Expected Results:  
should copy the port number into all fields.
(Assignee)

Comment 1

14 years ago
SOCKS not being copied is intended behaviour, since this is basically lifted
from IE.

This works for me just fine in a week-old build.

Comment 2

14 years ago
I can confirm the bug on Firefox 1.0. 
When "use the same proxy for all protocols" is enabled, the http proxy name and
port number fields are not copied to the the dependend proxy fields (https, ftp
etc.) if the dialog is left with the return key directly after editing the
value. Using the Ok button works fine with my browser.

I suppose the copying routine is triggered once the proxy field loses focus,
which does not happen if you leave the dialog with RETURN.
(Assignee)

Comment 3

14 years ago
Now, if that's what the reporter is seeing, then we can just morph the bug,
otherwise I'll have to file a new bug.
(Reporter)

Comment 4

14 years ago
yeah, that's exactly it. :)
i only noticed it was a loseFocus bug after i tinkered around with it for a
couple of days.

Comment 5

14 years ago
Exactly the same behaviour under Linux/GTK, FF 1.0
(Assignee)

Comment 6

14 years ago
*cough*isuckfornotthinkingaboutthis*cough*

I'll fix this at some point, in the meantime click OK instead of hitting Enter. :)
Assignee: firefox → mconnor
Target Milestone: --- → Firefox1.1
(Reporter)

Comment 7

14 years ago
Just tried it with a trunk build, bug finally fixed :D
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 8

12 years ago
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.