Crash when using font 'ms sans serif'

RESOLVED DUPLICATE of bug 180309

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 180309
14 years ago
13 years ago

People

(Reporter: Steven, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

69 bytes, text/html
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040928 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040928 Firefox/0.9.3

When I open a page like the demonstration URL (http://www.heijtel.nl/bug.html)
on my Debian machine Mozilla and Mozilla Firefox crash immediatley with a
segmentation error. I can't find any problems with that font in other browsers
(konqueror, Opera etc.).

Reproducible: Always
Steps to Reproduce:
Make a webpage with the following content:
***************START************
<html>
<body>
<font face="ms sans serif">test</font>
</body>
</html>
**********END**********

Go to it and it will happen.
Actual Results:  
Browser crashes with segmentation fault.

Expected Results:  
Show me the webpage with that font replaced for a default font.

I can't reproduce this bug on other machines (tried Windows and Sun)
(Reporter)

Comment 1

14 years ago
Created attachment 161489 [details]
Example

Updated

14 years ago
Keywords: crash

Comment 2

14 years ago
Works fine for me on Linux. Reporter please post a unstipped stack trace of the
crash.

Comment 3

14 years ago
dupe of "Xft Crash while loading page with MS .fon font [@ GetNormalLineHeight]"

*** This bug has been marked as a duplicate of 180309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.