Tab clutter causes confusion. Use Group Tabbed Browsing to enhance productivity. In principle, a group tab contains multiple other member tabs.

RESOLVED DUPLICATE of bug 233941

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 233941
13 years ago
13 years ago

People

(Reporter: Sharad Popli, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I'd like to propose an enhancement. Grouped Tabbed Browsing (GTB). The principle
is simple: A group tab contains multiple other member tabs.

Currently, I sometimes avoid tab clutter, by opening up a top level link in a
new browser window (instead of a tab) and then tab browse within the new window.
This window thus serves effectively as container (or a group tab) for a related
set of tabs. This is a work around. IMO, a group tab solution, which seems like
a logical progression, would be a more elegant approach. As illustrated below.

Example scenario
You come across a topic which you feel may have a lot of other related pages and
you'd like to keep them together. You are on link number 1 and you decide that
you'd like this to be part of its own group. Okay, so instead of middle-click,
you do <Some Key>+Middle Click, and voila, it opens up in a new group tab. All
subsequent middle clicks work as normal, opening up tabs in the background and
automatically associating them with the current group tab. You want another
group? No problems. <Some Key>+Middle Click...

Clicking on one of multiple group tabs, would make it active and fill the
browser window with all its member tabs. The other tabs would disappear into
their group tab, thus reducing clutter and improving organization. The group tab
could also be used to conveniently control all other members of the group. Say
bookmark all pages of a group. Or close or save or maybe forward them all.

One would need to think this entire thing through in more detail, but these are
top of mind ideas.

Read the complete scenario at:
http://sharadware.com/archives/2004/08/beyond_tabbed_b.html

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
If this is a suggestion -not a bug- I would like to make one too ;)
It would be good idea to make it so you can scroll the tab area if you have
heaps of tabs open.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 233941 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.