Mouse-wheel scrolling doesn't work in CSS-emulated frames

VERIFIED DUPLICATE of bug 97283

Status

()

Firefox
General
--
minor
VERIFIED DUPLICATE of bug 97283
14 years ago
14 years ago

People

(Reporter: David Holmes, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Emulating frames in CSS, for premium conformance to latest XHTML 1.1 & CSS 2.1
standards, is difficult but not impossible. As long as you're willing to settle
for percentage-relative heights and not fixed ones, if you want to work with IE.
And as long as you don't mind not being able to mouse-wheel scroll in your
pseudo-frames, in FireFox.

Having created a frames-like layout with position:absolute and overflow:auto
<div>s, whenever there is indeed some overflow a scrollbar neatly appears (and
more intelligently in FireFox than in IE), and of course clicking and dragging
the scrollbar, as well as clicking the top and bottom arrows, will scroll the
content. But rolling the mouse wheel over such a pseudo-frame, even with focus
forced by clicking inside it, does NOT scroll the content.

Surely it should, at worst with focus forced ; it should surely behave as with
an <iframe>.

BTW, the motivation here for emulating frames with CSS is XHTML 1.1 conformance
; and because frames are a creation of the Devil(tm), anyway.

The URL given, http://www.exaton.net/bugzilla/test-cssframes-mwscroll.html ,
demonstrates the difficulty.

Note : using overflow: -moz-scrollbars-vertical instead of overflow: auto
doesn't change anything.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.exaton.net/bugzilla/test-cssframes-mwscroll.html
2. Try to mouse-wheel scroll in either of the pseudo-frames (bottom left and right)
3. Constate lack of scrolling.

Actual Results:  
One definitely constates that the pseudo-frames are not vertically scrolled by
the mousewheel, as they are in IE, as they would be with frames or with iframes.
At least, with FireFox 1.0 PR, under WinXP.2600.SP2 (but happened before SP2
also, no need to blame every single mishap on the retched thing)...

Expected Results:  
I believe FireFox should scroll CSS-emulated pseudo-frames the way it would
frames, or iframes, when the mouse wheel is rolled as much as when the scrollbar
is used "manually".

No crash, just a pretty annoying ergonomy hole... Believed to happen with all
themes, but I'm using the popular Noïa 2 eXtreme.
(Reporter)

Comment 1

14 years ago
Created attachment 161496 [details]
Testcase identical to the URL given, in case it goes down.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 97283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: Mouse-wheel scrolling doesn't work in CSS-emulated frames → Mouse-wheel scrolling doesn't work in CSS-emulated frames
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.