Ctrl + makes the homepage completely garbage!

VERIFIED INVALID

Status

SeaMonkey
General
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: Parag Warudkar, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Browse to http://www.compusa.com. Hit Ctrl+, watch the page layout going for a
toss each time. I don't know how to explain what exactly happens, so I am
attaching screenshots. 

Reproducible: Always
Steps to Reproduce:
1.Browse to http://www.compusa.com. 
2.Hit Ctrl+, watch the page layout going for a toss each time. 
3.Feel bad ;)

Actual Results:  
Page layout was distorted.

Expected Results:  
Should have either not allowed to increase the text size or otherwise would have
rendered the page without distorting the layout.

IE doesn't increase size on the compusa homepage. Don't know if this is relevant.
(Reporter)

Comment 1

13 years ago
Created attachment 161525 [details]
Normal Rendering

Without increasing the Text size.
(Reporter)

Comment 2

13 years ago
Created attachment 161527 [details]
Ctrl+ One Render

Page after pressing Ctrl+ once. Notice the overlapped menus.
(Reporter)

Comment 3

13 years ago
Created attachment 161528 [details]
Ctrl+ Twice Render

Totally distorted layout.

Comment 4

13 years ago
That's not a browser bug.  The code/layout of their page is just written
assuming fixed text sizes, and it has no flexibility to adjust to larger ones.

This is either invalid, or a Tech Evangelism bug.
(Reporter)

Comment 5

13 years ago
That's probably why IE doesn't react to View->Text Size->* on this site. If
there is a way to determine such inflexible code which assumes Fixed Text sizes,
can we not ignore to react to Ctrl+ in such cases? Probably would help avoid the
feeling of Browser doing something odd.

Comment 6

13 years ago
(In reply to comment #5)
> That's probably why IE doesn't react to View->Text Size->* on this site. If
> there is a way to determine such inflexible code which assumes Fixed Text sizes,
> can we not ignore to react to Ctrl+ in such cases? Probably would help avoid the
> feeling of Browser doing something odd.


Bad idea. Ctrl+ isnĀ“t about showing beautiful sites, it is essential for people
with bad eyesight to increase the fontsize, no matter how the rest is rendered.
It is better to see a distorted site than seeing nothing.

Comment 7

13 years ago
It would also put us in violation of one of the User Agent Accessibilty Guidelines.
http://w3.org/TR/2002/REC-UAAG10-20021217/guidelines.html#tech-configure-text-scale

I'm going to call this invalid.  Someone could make it a TE bug if they feel the
need.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

13 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

13 years ago
I wasn't aware of the relation between Ctrl+ and accessibility - From that point
of view it is a bad/terrible/violating idea to not respond to Ctrl+ but for the
 most common case of end user with normal eyesight (wanting to increase the font
size due to high resolution display he uses) who doesn't understand the W3c
standard and HTML/CSS coding standards, it still makes sense to atleast warn the
user - "This site uses fixed font sizes and may not render properly with
non-default text sizes. Do you want to continue?" 

(Ok that wording may be made better, but it gives an idea!)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.