Layout problem with (un)ordered lists up against left justified table

RESOLVED DUPLICATE of bug 57882

Status

()

RESOLVED DUPLICATE of bug 57882
14 years ago
14 years ago

People

(Reporter: kema, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

The included test case is a distilled example of a problem I ran into when using
left justified tables to have text wrap around an image with a caption. Note
that there is a narrow column to the right of the image to provide a small
amount of separation between the image and the text that wraps around it. Normal
paragraph text is aligned as expected and the problem in alignment only seems to
show up when a list (ordered or unordered) abutts the table.

Reproducible: Always
Steps to Reproduce:
1. Display the associated test case URL in a browser.
2. Stare at the computer screen.
3. Note the problem as it appears before your eyes (Note: problem goes away when
eyes are closed).

Actual Results:  
The problem of <ol> text abutting a left justified table is displayed in the
first list. The text is too far to the left (overlapping the table).

Expected Results:  
The second example shown in the test case is what the code should have produced.

Comment 1

14 years ago
Created attachment 161552 [details]
standardized minimized testcase

This is a dup of bug 57882.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 57882 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

14 years ago
Obviously my search to see if this was an existing bug used the wrong keywords
as I did not find the other 31 times that this bug has been reported over the
last 4 years. Not being familiar with the underlying layout code it would seem
like a simple problem to fix but apparently it is not or it would not be around
for this long (only 21 more years and it can retire with a gold watch)...

If it is this difficult to get basic HTML layout bugs fixed, I thank my lucky
stars that I am not part of the development effort for Mozilla. (They don't make
aspirin bottles that large - even at Sam's Club or Cosco)....
You need to log in before you can comment on or make changes to this bug.