HTML BODY tags override system settings for font color

VERIFIED INVALID

Status

Thunderbird
Preferences
VERIFIED INVALID
14 years ago
13 years ago

People

(Reporter: Joe Sislow, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

The following message ignores my font settings for the font color, and as a
result, the text is black on my black background.  I believe Thunderbird is
overriding my settings and paying attention to the BODY field's settings for
COLOR: #000000

----


From - Fri Oct  8 15:37:01 2004
X-Account-Key: account3
X-UIDL: 4165606d00000157
X-Mozilla-Status: 0011
X-Mozilla-Status2: 00000000
Return-Path: <ADDRESS_REMOVED>
Received: from hotmail.com (bay5-dav14.bay5.hotmail.com [65.54.172.118])
	by SERVER_REMOVED (8.11.6/8.11.6) with ESMTP id i98KYHv23520
	for <ADDRESS_REMOVED> Fri, 8 Oct 2004 15:34:19 -0500
Received: from mail pickup service by hotmail.com with Microsoft SMTPSVC;
	 Fri, 8 Oct 2004 13:34:01 -0700
Received: from 64.105.19.102 by BAY5-DAV14.phx.gbl with DAV;
	Fri, 08 Oct 2004 20:33:13 +0000
X-Originating-IP: [IP_REMOVED]
X-Originating-Email: [ADDRESS_REMOVED]
X-Sender: ADDRESS_REMOVED
From: <ADDRESS_REMOVED>
To: <ADDRESS_REMOVED> <ADDRESS_REMOVED>
Cc: <ADDRESS_REMOVED> <ADDRESS_REMOVED> <ADDRESS_REMOVED>
References: <ADDRESS_REMOVED>
Subject: Re: Clyde-Brummel park drop-in program
Date: Fri, 8 Oct 2004 15:33:15 -0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
	boundary="----=_NextPart_000_00C2_01C4AD4C.2154C5A0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: MSN 9
X-MimeOLE: Produced By MSN MimeOLE V9.10.0006.2205
Seal-Send-Time: Fri, 8 Oct 2004 15:33:16 -0500
Message-ID: <ADDRESS_REMOVED>
X-OriginalArrivalTime: 08 Oct 2004 20:34:01.0359 (UTC) FILETIME=[251C89F0:01C4AD76]
X-Spam-Checker-Version: SpamAssassin 2.63 (2004-01-11) on SERVER_REMOVED
X-Spam-Status: No, hits=-4.7 required=5.0 tests=BAYES_00,HTML_MESSAGE,
	MISSING_OUTLOOK_NAME autolearn=no version=2.63
X-Spam-Level: 
Status:   

This is a multi-part message in MIME format.

------=_NextPart_000_00C2_01C4AD4C.2154C5A0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Here are my thoughts in regards to some of the responses to the original =
comments. We maybe be getting off track.

I personally like the new re-planned park and enjoy seeing the families =
using the park.=20

At the meeting nor now do I see this as an issue with the Program itself =
or the kids that attend the program....

What I recall was mentioned at the meeting, was the negative quality of =
life issues directly involved with the Program which we were hoping to =
have addressed:=20

#1 the issue with the appearance of the trailer (we call the park, =
affectionately "Trailer Park")... The trailer is there to serve the =
program.
#2 the amount of monitors / counselors to kids ratio... safety!!!
#3 the trash in the park and what gets trailed out of the park and down =
our streets.=20

*The response from the city was that due to the changes in the =
neighborhood, the Program maybe better located in the Elmwood Park or =
elsewhere and they promised to look into it.

The neighbors have been pushing to see the trailer go or replaced with =
something that architecturally fits our neighborhood since we originally =
meet as a community to re-plan the park (the same two meetings that got =
the basketball court removed). At our last meeting (09/30/04), I was =
very impressed with the unanimous agreement on this issue. I have no =
doubt Ann is pushing hard to make sure these issues are addressed not =
just for the kids but also for the general feel and appearance of our =
neighborhood. I think the City Manager got our point. Till the issue of =
the trailer is resolved, I hope that the city continues to improve on =
issues #2 and #3....=20

Abe

PS. If the City removed the basketball court for us (which reduced the =
problems by 90%), I'm sure they'll address the issue with the trailer.
  ----- Original Message -----=20
  From: ADDRESS_REMOVED<mailto:ADDRESS_REMOVED>=20
  To: =
ADDRESS_REMOVED<mailto:ADDRESS_REMOVED>=20
  Cc: ADDRESS_REMOVED<mailto:ADDRESS_REMOVED> 
  Sent: Thursday, October 07, 2004 4:59 PM
  Subject: Re: Clyde-Brummel park drop-in program


  Look all, we are working on relocating this program. The city promotes =
programs a year in advance. You cannot dismantle this overnight. If you =
come from a community  where this happens please let me know. I would be =
happy to consult with them to determine their process

  Please keep in mind that the 8th ward takes in more than just Callan =
and Clyde. My constituents are using the Clyde Brummel park even though =
they do not live on your 2 blocks. We just cannot move them out this =
month. We have been working on a location as we promised. Please be =
patient. Also, keep in mind that I have been lobbying for the move of =
the trailer long before I met with you last week.=20


  NAME_REMOVED
  #_REMOVED
  Great 8th Ward Message Board =
Index<http://www.quicktopic.com/share?s=3D5K4z>=20
  Evanston Police Daily Bulletin - crimes and =
arrests<http://www.cityofevanston.org/departments/police/reports/index.sh=
tml>=20
  City of Evanston Web Page!<http://www.cityofevanston.org/>=20

  About My =
Place<http://www.cityofevanston.org/AboutYou/?name=3Dwhoami&Cmd=3Dwhoami&=
User=3D1&house_number=3D&street_id=3D&Submit=3DSubmit>=20

  New Residents<http://www.cityofevanston.org/resident/new.shtml>=20



------=_NextPart_000_00C2_01C4AD4C.2154C5A0
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type =
content=3Dtext/html;charset=3Diso-8859-1>
<META content=3D"MSHTML 6.00.2800.1458" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY id=3DMailContainerBody=20
style=3D"PADDING-LEFT: 10px; FONT-WEIGHT: normal; FONT-SIZE: 10pt; =
COLOR: #000000; BORDER-TOP-STYLE: none; PADDING-TOP: 15px; FONT-STYLE: =
normal; FONT-FAMILY: Verdana; BORDER-RIGHT-STYLE: none; =
BORDER-LEFT-STYLE: none; TEXT-DECORATION: none; BORDER-BOTTOM-STYLE: =
none"=20
bottomMargin=3D7 leftMargin=3D0 topMargin=3D0 rightMargin=3D7 =
acc_role=3D"text"=20
CanvasTabStop=3D"true" name=3D"Compose message area"><!--[gte IE =
5]><?xml:namespace prefix=3D"v" /><?xml:namespace prefix=3D"o" =
/><![endif]-->
<DIV style=3D"FONT-SIZE: 10pt; COLOR: #000000; FONT-FAMILY: Arial">
<DIV>
<DIV>Here are my thoughts in regards to some of the responses to the =
original=20
comments. We maybe be getting off track.</DIV>

<DIV>&nbsp;</DIV>
<DIV>I personally like the new re-planned park and enjoy seeing=20
the&nbsp;families using the park.&nbsp;</DIV>
<DIV>&nbsp;</DIV>
<DIV>At the meeting nor now&nbsp;do I&nbsp;see this as an issue with the =
Program=20
itself or the kids that attend the program....</DIV>
<DIV>&nbsp;</DIV>

<DIV>What I recall was mentioned at the meeting, was the negative =
quality of=20
life issues&nbsp;directly involved with the Program which we were hoping =

to&nbsp;have addressed: </DIV>
<DIV>&nbsp;</DIV>
<DIV>#1 the issue with the appearance of the trailer (we call the park,=20
affectionately "Trailer Park")... The trailer is there to serve the=20
program.</DIV>
<DIV>#2 the amount of monitors / counselors to&nbsp;kids ratio...=20
safety!!!</DIV>
<DIV>#3 the trash in the park and what gets trailed out of the park and =
down our=20
streets. </DIV>
<DIV>&nbsp;</DIV>

<DIV>*The response from the city was that due to the&nbsp;changes in the =

neighborhood,&nbsp;the&nbsp;Program maybe&nbsp;better located in the =
Elmwood=20
Park or elsewhere and they promised to look into it.</DIV>
<DIV>&nbsp;</DIV>
<DIV>The neighbors have been&nbsp;pushing to see the trailer go or =
replaced with=20
something that architecturally fits our neighborhood since we originally =
meet as=20
a community to re-plan the park (the same two meetings that got the =
basketball=20
court removed). At our&nbsp;last&nbsp;meeting (09/30/04), I was very =
impressed=20
with the unanimous&nbsp;agreement&nbsp;on this issue. I have no =
doubt&nbsp;Ann=20
is pushing hard to make sure these issues are addressed not just for the =
kids=20
but also for the general feel and appearance of our neighborhood. =
I&nbsp;think=20
the City Manager got our point.&nbsp;Till&nbsp;the issue of the trailer =
is=20
resolved,&nbsp;I hope that the city continues to improve on issues #2 =
and #3....=20

</DIV>
<DIV>&nbsp;</DIV>
<DIV>Abe</DIV>
<DIV>&nbsp;</DIV>
<DIV>PS. If the&nbsp;City&nbsp;removed the basketball court&nbsp;for us =
(which=20
reduced the problems by 90%), I'm sure they'll address the issue with =
the=20
trailer.</DIV></DIV>
<BLOCKQUOTE dir=3Dltr=20
style=3D"PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; =
BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  <DIV style=3D"FONT: 10pt arial">----- Original Message ----- </DIV>
  <DIV style=3D"FONT: 10pt arial"><B>From:</B> <A =
title=3Dmailto:ADDRESS_REMOVED=20
  href=3D"mailto:ADDRESS_REMOVED">ADDRESS_REMOVED</A> </DIV>
  <DIV style=3D"FONT: 10pt arial"><B>To:</B> <A=20
  title=3Dmailto:ADDRESS_REMOVED=20
  =
href=3D"mailto:ADDRESS_REMOVED">ADDRESS_REMOVED=
net</A>=20
  </DIV>
  <DIV style=3D"FONT: 10pt arial"><B>Sent:</B> Thursday, October 07, =
2004 4:59=20
  PM</DIV>
  <DIV style=3D"FONT: 10pt arial"><B>Subject:</B> Re: Clyde-Brummel park =
drop-in=20
  program</DIV>
  <DIV><BR></DIV><FONT id=3Drole_document face=3DArial color=3D#000000 =
size=3D2><FONT=20
  lang=3D0 face=3DArial size=3D2 FAMILY=3D"SANSSERIF" PTSIZE=3D"10">
  <DIV>Look all, we are working on relocating this&nbsp;program. The =
city=20
  promotes programs a year in advance. You cannot dismantle this =
overnight. If=20
  you&nbsp;come from a community &nbsp;where this happens please let me =
know. I=20
  would be happy to consult with them to determine their process</DIV>
  <DIV>&nbsp;</DIV>
  <DIV>Please keep in mind that the 8th ward takes in more than just =
Callan and=20
  Clyde. My constituents are using the Clyde Brummel park even though =
they do=20
  not live on your 2 blocks. We just cannot&nbsp;move them out this =
month. We=20
  have been working on a location as we promised. Please be patient. =
Also, keep=20
  in mind that I have been lobbying for the move of the trailer long =
before I=20
  met with you last week. </DIV>
  <DIV>&nbsp;</DIV>
  <DIV><U></U><U><BR></U>NAME_REMOVED<BR>#_REMOVED<U><BR><A=20
  title=3Dhttp://www.quicktopic.com/share?s=3D5K4z=20
  href=3D"http://www.quicktopic.com/share?s=3D5K4z">Great 8th Ward =
Message Board=20
  Index</A> <BR><A=20
  =
title=3Dhttp://www.cityofevanston.org/departments/police/reports/index.sh=
tml=20
  =
href=3D"http://www.cityofevanston.org/departments/police/reports/index.sh=
tml">Evanston=20
  Police Daily Bulletin - crimes and arrests</A><U> <BR><A=20
  title=3Dhttp://www.cityofevanston.org/=20
  href=3D"http://www.cityofevanston.org/">City of Evanston Web =
Page!</A><U>=20
  </U><BR><BR><A=20
  =
title=3Dhttp://www.cityofevanston.org/AboutYou/?name=3Dwhoami&amp;Cmd=3Dw=
hoami&amp;User=3D1&amp;house_number=3D&amp;street_id=3D&amp;Submit=3DSubm=
it=20
  =
href=3D"http://www.cityofevanston.org/AboutYou/?name=3Dwhoami&amp;Cmd=3Dw=
hoami&amp;User=3D1&amp;house_number=3D&amp;street_id=3D&amp;Submit=3DSubm=
it">About=20
  My Place</A> </U></U></DIV>
  <DIV><U><U></U></U>&nbsp;</DIV>
  <DIV><U><U><A title=3Dhttp://www.cityofevanston.org/resident/new.shtml =

  href=3D"http://www.cityofevanston.org/resident/new.shtml">New =
Residents</A>=20
  =

<BR><BR><BR></DIV></BLOCKQUOTE></U></U></FONT></FONT></DIV></BODY></HTML>=


------=_NextPart_000_00C2_01C4AD4C.2154C5A0--



Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
It should have used the existing text settings for HTML text from
Tools->Options->Display->HTML Messages.

Comment 1

13 years ago
This is by design; message is supposed to be able to set its own colors, and 
this one simply did not specify the background color, which it should have if it 
bothered to specify the text color.

The current override feature is to use   View | Message Body As | Simple HTML.
This is overkill for the desired effect, as all formatting will be stripped, 
external images not displayed, and many other HTML features suppressed.

You could repurpose this bug to request a Color Override feature; otherwise, you 
should close it by marking it:   Resolved | Invalid

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.