If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Parallel splitters in boxes jump when resizing

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: djpohly, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

591 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

When viewing an XUL page with multiple splitters, resizing panes on an inner
level before those on an outer level causes the splitters to jump.  This is
difficult to explain so an example is forthcoming.

Reproducible: Always
Steps to Reproduce:
1. Load a page with more than one level of splitters that go in the same direction.
2. Drag an inner splitter.

Actual Results:  
Both the inner and outer splitters jump.

Expected Results:  
The inner splitter should follow the mouse drag, and the outer one should stay put.

Using Plastikfox Crystal SVG theme.
(Reporter)

Comment 1

13 years ago
Created attachment 161539 [details]
Testcase

Aforementioned testcase.

Also: Bug still present with default theme.

Comment 2

13 years ago
Splitters work by changing the width attributes on your boxes. This assumes that
the overall preferred size is not affected by the individual preferred sizes of
the split boxes. For instance, for the outermost boxes the overall preferred
size is simply the window's inner width. However your left box doesn't have a
preferred size so that you change the split the new width attributes will also
give the left box a preferred size giving rise to the effect you describe. The
easy way to work around the problem is to specify a preferred size on the parent
box of the splitter (in your case width="1" works). You don't see the problem
after you move the outer splitter because it gives the vbox a preferred width.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.