Closed Bug 263572 Opened 16 years ago Closed 16 years ago

URLS in back/forward navigation history case insensitive

Categories

(Core :: DOM: Navigation, defect)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 99091

People

(Reporter: bugs, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1

The URLS in the back/forward history seemed to be stored/compared case
insensitively.  It's a bit difficult to explain, so look at my steps to
reproduce and the actual/expected results and you'll realize that this is a
quite a usability issue with most sites.  

Reproducible: Always
Steps to Reproduce:
1. Go to http://en.wikipedia.org/ via the URL bar
2. Go to http://en.wikipedia.org/wiki/Alexander_The_Great via the URL bar
3. Go to http://en.wikipedia.org/wiki/Alexander_the_Great via the URL bar
4. Press the Back button.

Actual Results:  
You are returned to http://en.wikipedia.org/

Expected Results:  
You should be returned to http://en.wikipedia.org/wiki/Alexander_The_Great

Obviously the two URLs http://en.wikipedia.org/wiki/Alexander_The_Great and
http://en.wikipedia.org/wiki/Alexander_the_Great are being compared case
insensitively and therefore appear to be the same page, when they are not.  Most
web sites have case sensitve URLs so this really should be fixed.
Unless Firefox has forked the session history (unlikely, but I'm not sure),
that's a dup of bug 99091

*** This bug has been marked as a duplicate of 99091 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Component: General → History: Session
Product: Firefox → Browser
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Component: History: Session → Document Navigation
QA Contact: general → docshell
You need to log in before you can comment on or make changes to this bug.