Closed Bug 263600 Opened 16 years ago Closed 16 years ago

Firefox won't save the css file when choosing 'Web Page, complete' with this page

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 126309

People

(Reporter: Athropos, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041008 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041008 Firefox/0.10

When you try to save this complete page, the css file isn't saved with all the
other files.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.lifl.fr/~carle/index.html
2. Choose 'Save page as...'
3. Select 'Web Page, complete'
4. Open the file from your hard disk

Actual Results:  
The layout has been lost because the css file wasn't saved

Expected Results:  
The css file should have been saved

I have tried with other webpages and the css file is correctly saved. I guess
this is because this page uses a special method to tell which css file it uses:
<style type="text/css" media="all">@import "./css/monstyle.css";</style>

However, it is validated by the w3c validator and correctly taken into account
by firefox, so it should be correctly saved.

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.