Firefox does not detect installed Shockwave plugin when visiting sites using Shockwave

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
4 years ago

People

(Reporter: happyoutkast, Assigned: doronr)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Whenever I attempt to visit any site using shockwave flash plugins, firefox
alerts that it requires a missing plugin. I run thru the installation process
many times, it always says flash player is installed yet I revisit the site and
I keep getting the message that the plugin is required and the shockwave flash
applets do not display. This also occurs when installing flash player directly
off of the macromedia website. It runs thru the installer, then once the
installer is completed it goes to the installation completed site (with
shockwave applets included) and says that the plugin is needed, shockwave applet
is not displayed.

Reproducible: Always
Steps to Reproduce:
1. Go to a site using shockwave flash (e.g. www.shockwave.com)
2. Click on action games link on the webpage.
3. Select any game of choice and try to play it (I was trying Tank Wars)
4. Select play online for the game chosen
5. Select high bandwidth in the window that pops up.
6. Firefox should alert that a browser plugin is needed, download and install
plugin as prompted.
7. The web page for the game should now refresh, Firefox should now inform you
that a browser plugin is needed to view the shockwave applet, even though the
installation process was just completed.
8. Repeat steps 4-7 as many times as desired or until the urge to grab a heavy
blunt object becomes overwhelming.

Actual Results:  
The shockwave flash plugins continue to not work in firefox. Strangely I
continued using firefox to check my email online for the password for bugzilla,
then revisited the shockwave site and got the same error again (not surprising)
but after trying to reload the page it actually ran part of the shockwave
applet. . .then gave in error and looped back to the beginning menu "high
bandwidth" and "low bandwidth"

Expected Results:  
It should have run the shockwave flash applet after installing the plugin. It
seems that firefox has a hard time associating with the flash player and using
it properly.

I was using the default theme on a windows 2000 based os, with an hp 6540c
(celeron 466mhz with 96 MB ram). No dialog boxes or error messages "popped" up.

Comment 1

14 years ago
I'm running on Win2K:
  Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3)
  Gecko/20041001 Firefox/0.10.1

Following the "How to remove Shockwave Player from my computer" instructions
on: <http://www.macromedia.com/support/shockwave/ts/documents/playerfaq.htm#10_2>
(I ran C:\WINNT\system32\Macromed\Shockwave 8\UNWISE.EXE)

The symptoms you discribe (plugin says its installed) persist, but if I
go to: <http://www.macromedia.com/downloads/> and download the executable,
run it, it notices the firefox installation, and installs just fine
everything works for me now.

Comment 2

14 years ago
Flash also doesn't work for 1.0RC1 for Mac. Confirmed by Macromedia's test page.
This is a serious bug for Mac!
I just tried this using Firefox 1.0rc1 and had no problems.  You have to be
careful of the sites listed above because they sniff to see if you have Flash
installed first, and make it so Firefox doesn't kick off its plugin download
service.

Here's what I did to test this:
1) Visit www.orisinal.com.  You should see a large area that should be flash,
but has the jigsaw piece.  At the top, you should see Firefox's plugin finder.
2) Click on the plugin finder to install the missing plugin.  It finds Flash
7.0.  I go through the steps to install it.
3) After the plugin is installed, it reloads the page, and now it works as expected.

After the plugin was installed, I checked /Library/Internet Plug-ins folder and
saw Flash Player.plugin listed, as expected

Comment 4

14 years ago
confirmed with the exact same results...  installation attempted, but plugin
never works. A testcase can be found here...

http://www.albinoblacksheep.com/flash/junkbot.html

Comment 5

14 years ago
If this is true, I'm hoping it can (and will) be fixed before FF1.0 final...
nominating, since this sounds like a nasty bug that shouldn't be left in. If not
reproducable, then go ahead and shout me down.
Flags: blocking-aviary1.0?
Flash is not the same as Shockwave (despite the "Shockwave Flash" name).

WFM: once you install shockwave as prompted these things work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 7

14 years ago
So this is only about Flash? -> Reducing summary to that.
http://www.macromedia.com/shockwave/welcome/ is a test page for both Shockwave
and Flash.
Summary: Firefox does not detect installed flash player plugin when visiting sites using shockwave flash. → Firefox does not detect installed flash player plugin when visiting sites using flash

Comment 8

14 years ago
This is strictly shockwave, not flash. The site you posted...

http://www.macromedia.com/shockwave/welcome/

is more proof at least on my system that shockwave is not installing properly
with firefox... the shockwave will not work, while the flash does.

Comment 9

14 years ago
Ok, for me, this IS the flash player, not shockwave (that doesn't work either).
After installing the plugin, I went to this site http://www.clarks.co.uk/(which
uses flash) despite the fact that I have the plugin installed, the website did
not run, it showed "requires plugin". O/S Windows XP fox: 1.0PR

Comment 10

14 years ago
Changing the summary again, to Shockwave, after rereading comment 0 thoroughly.
Sorry for spamming.

Both Flash and Shockwave work fine here.
Flags: blocking-aviary1.0?
Summary: Firefox does not detect installed flash player plugin when visiting sites using flash → Firefox does not detect installed Shockwave plugin when visiting sites using Shockwave

Comment 11

14 years ago
Perhaps it's not installing properly because I'm using a self extracting
optimized build that can't find the plugins folder, but anyways, the problem for
me was the file np32dsw.dll not being copied to the firefox plugins folder when
shockwave was installed. I fixed this by downloading the file manually and
extracting it into the plugins folder. FYI, the file can be downloaded here...

http://liewcf.com/wp/archives/2004/07/install-shockwave-player-for-standalone-firefox/

If this is just a problem with optimized builds and not the regular standard
installation, then it's no problem. I suggest uninstalling or deleting your
plugins folder to test for sure whether this problem actually exists.
(Reporter)

Comment 12

14 years ago
I find that the bug at least exists as far as (1) firefox's plugin 
finder/installer on a variety of platforms, and (2) the optimized install 
files used to install shockwave/flash downloaded from the macromedia website. 
At very least I would expect to see the bug with firefox's plugin 
finder/installer fixed since the install file (optimized build) is not the 
firefox developer's problem.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 13

14 years ago
Is anyone still seeing this? Note that 64 bit oseswon't get a working flash.
(Assignee)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.