script from site opens javascript console

RESOLVED DUPLICATE of bug 243170

Status

Toolkit Graveyard
Error Console
--
major
RESOLVED DUPLICATE of bug 243170
13 years ago
a year ago

People

(Reporter: Peter6, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows 2000

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041009
Firefox/0.10

repro:
1. open http://www.emule-france.com/index.php
2. go to the "home" image (image name = p_header_minilogo2.gif ) in the top-right.
3. press on it.
4. the javascript console pops up with the message
--Error: this.setHomePage is not a function--

script doing this is:

document.write('<a href="javascript:"
onclick="javascript:this.style.behavior=\'url(#default#homepage)\';this.setHomePage(\'http://www.emule-france.com/\')"><IMG
SRC="http://www.emule-france.org/images/p_header_minilogo2.gif" BORDER=0
WIDTH="30" HEIGHT="20" ALT="faire de emule-france ma page de démarrage"
align="absbottom"></a>');

exp:
an external site should not be able to open the javascript console.
(Reporter)

Comment 1

13 years ago
Created attachment 161577 [details]
testcase

open testcase and click on "click here"
Related to bug 243170, maybe even a duplicate.
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Related to bug 243170, maybe even a duplicate.
I agree Martijn
scr="javascript:" is the common part.

Duping this one



*** This bug has been marked as a duplicate of 243170 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.