Links in downloads window can't be activated with keyboard

VERIFIED DUPLICATE of bug 256243

Status

()

Firefox
Keyboard Navigation
P1
major
VERIFIED DUPLICATE of bug 256243
13 years ago
12 years ago

People

(Reporter: Philip Ross, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug, {access, helpwanted, sec508})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

The links that appear in the Downloads window against downloaded files (cancel,
open, retry, remove) cannot be activated using the keyboard.

You can tab round the links and the focus visibly moves, however pressing enter
does not activate the link and perform the action. To activate the link, the
user has to use the mouse.

Reproducible: Always
Steps to Reproduce:
1. Download a file.
2. Activate the Downloads window.
3. Use tab to focus one of the cancel, open, retry or remove links.
4. Press enter.

Actual Results:  
Nothing happens on pressing enter.

Expected Results:  
The link action should be performed in the same way as when clicking the link
with the mouse.

Possibly related to bug 260879 (changing the links to buttons).
(Assignee)

Updated

13 years ago
Blocks: 204402
Keywords: access
(Assignee)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: sec508
(Assignee)

Comment 1

13 years ago
Also related to bug 256243
Severity: minor → major
Flags: blocking-aviary1.1?
Priority: -- → P1
(Assignee)

Updated

13 years ago
Keywords: helpwanted
(Assignee)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 256243 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

13 years ago
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.