Reply from Local Folder does not use original To or CC from mail being replied to.

VERIFIED DUPLICATE of bug 252103

Status

Thunderbird
Message Compose Window
VERIFIED DUPLICATE of bug 252103
13 years ago
13 years ago

People

(Reporter: Bill Schmitt, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Thunderbird version 0.8 (20040913)

After looking throug the bug reports, I've seen similar issues here, but not
this specific one. When reviewing the contents of the local folder and seeing a
need for a response, if I select Reply, the outgoing address is not the address
to which the message had been sent, but rather my default email for general
mail. On several occasions, I've missed it and my own reply has gone out using
the wrong account. That doesn't seem crystall clear, so here's a scerio.

1. Two mailboxes are set up: publicaddress@mydomain.com and
privateaddress@mydomain.com with separate servers specified for sending.

2. Mail sent as publicaddress@mydomain.com to support@someoneelse.com

3. Reply comes into inbox for publicaddress@mydomain.com from
support@someoneelse.com and is immediately filed in Local
Folders/someoneelsesupport.

4. I read it in Local Folders/someoneelsesupport and reply. The From line in the
Compose windows says privateaddress@mydomain.com.


Reproducible: Always
Steps to Reproduce:
1. Set up 2 mailboxes and a local folder
2. Forward specific mail in box 2 to the local folder
3. When mail comes into local folder, reply to it
4. The From address will be box 1.

Actual Results:  
Incorrect Mailbox listed. 

Expected Results:  
The From address should have been set to the recipient of the email being
replied to rather than the default email address.

Comment 1

13 years ago
Appears to be a dupe; see bug 254209 comment 10.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Appears to be a dupe; see bug 254209 comment 10.

At your suggestion, this morning (sorry for the delay but I was pulled into
something else) I downloaded ThunderbirdSetup.exe from
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/. I
deleted everything in the installed folder and reinstalled it. I opened the
Local Folders with a message to a non-default address. Clicking the reply button
yielded the same results (incorrect Reply-To). 

In case I'm missing something, the about box for Tbird now states .6+, which I
assume is related to the build process, since the date in the directory was 10-18.

Comment 3

13 years ago
(In reply to comment #2)
> In case I'm missing something, the about box for Tbird now states .6+, which I
> assume is related to the build process, since the date in the directory was
> 10-18.

If that ".6+" is an accurate indicator, then you wouldn't expect to see the fix; 
I haven't been using TB nightlies, but I would expect "0.8+".

Comment 4

13 years ago
trunk builds still show .6+, I believe.

Comment 5

13 years ago
(In reply to comment #2)
> I deleted everything in the installed folder and reinstalled it. I opened the
> Local Folders with a message to a non-default address. Clicking the reply
> button yielded the same results (incorrect Reply-To).

Was the message that you replied to one that had been received prior to getting 
the new build?  The patch included adding an X-Account-Key: header to the 
received messages; so replying to a message that was received earlier will still 
show the same results.
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> Was the message that you replied to one that had been received prior to 
getting 
> the new build?  The patch included adding an X-Account-Key: header to the 
> received messages; so replying to a message that was received earlier will 
still 
> show the same results.

No. The new attempt was executed immediately following the patch (there were 
no new messages to reply to yet). I just tried it again, with older messages 
and newer messages, and it appears that the newer messages use the correct 
FROM address. Thank you for the clarification. I will now change the 
resolution to 252103, as you suggested in answering an earlier request for 
information.

*** This bug has been marked as a duplicate of 252103 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.