Closed Bug 26367 Opened 20 years ago Closed 19 years ago

Mail headers should be possible to select

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 61497
Future

People

(Reporter: bugzilla, Assigned: mscott)

References

Details

(Keywords: helpwanted, Whiteboard: [nsbeta2-][nsbeta3-])

When in Mail/News it should be possible to select the text in the mail headers.
Currently when you move your mouse cursor over the mail headers the mouse cursor 
doesn't change into a vertical line like in Netscape 4.7

This goes both for mail headers in a original mail and in forwarded mails 
(where it's actually possible to select text but the cursor doesn't change).
Reassign to mscott
Assignee: phil → mscott
QA Contact: lchiang → laurel
Hmm since the mail header is now part of the 3-pane and not part of the iframe
containing the body this might be hard to pull off. In any case, this is a post
beta 1 bug.
Target Milestone: M17
*** Bug 35303 has been marked as a duplicate of this bug. ***
Shortening SUMMARY.

BTW: 4.7 is very annoying in that it produces a table. It is very hard to select
only the content (e.g. the email address - you can't do |copy link location|,
because this gives you an unusable address book URL) and I nearly always get a
lot of whitespace (from table fields) around it when I paste.
Summary: Mail headers should be possible to select (mouse cursor doesn't change to vertical line) → Mail headers should be possible to select
moving to future milestone.
Target Milestone: M17 → Future
Copying msg headers is a frequent action, e.g. when I manually refer to some msg
or copy an email address. Nominating for nsbeta2 and 3.
Keywords: nsbeta2, nsbeta3
Your kidding! This is so not a beta2 bug. I can't see anyone holding beta2 for 
this. I wouldn't even hold beta3 for it either actually so I guess I also 
disagree with the nsbeta3 nomination as well but that debate can be staved off 
for a later time =). 
mscott, I don't care *when* it is implemented, I just think, a product shouldn't
*ship* without this bug being fixed. If you disagree: Why? How can I fastly copy
the topic otherwise?
Putting on [nsbeta2-] radar. Not critical to beta2. 
Whiteboard: [nsbeta2-]
- per mail triage for Netscape release.
adding helpwanted for mozilla.org community to contribute fix for this to Mozilla.
Keywords: helpwanted
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3-]
*** Bug 47694 has been marked as a duplicate of this bug. ***
I agree -- I copy subject lines and sender addresses all the time in 4.x, and
have lost messages in mozilla because I had to type the recipient in by hand,
typed in in wrong, and then deleted the original message thinking I had replied
to the sender, and didn't find out 'til a day later that the message bounced.

I thought originally the mail headers weren't supposed to be part of the chrome
anyway -- they were supposed to scroll with the message as in 4.x (that's what
it said in the Mail UI spec, and there's an open bug on the fact that that
doesn't work).  One fairly easy fix for both issues at once would be to do what
4.x does, and do away with the much-maligned non-scrolling header frames
altogether, and display the message headers as part of the body content.  If
someone were to contribute a fix like that (perhaps under a pref, since
obviously someone must be attached to the idea of these header frames), would it
be accepted?
akk, should be easier than that. You just need to change the <html> or <text> or
whatever we use currently to a readonly textedit field. Data fields should never
the labels (which <html> and <text> are) for that very reason.
Your beating on a dead horse if you want headers to scroll with the body. we 
already have a bug for that and none of us have been able to figure out how to 
do it. hyatt says the implementation of an iframe needs to be modified for this 
to work.

the current implementation (where they don't scroll) is by necessity and not 
design.

mscott, I don't advocate scrolling headers, but didn't we shortly have them some
time ago (around M15, IIRC)?
sadly no, we've never had scrolling headers =(
mscott, yes, we did. See bug 34243, my comment at 2000-04-02 15:39. They were
introduced shortly before I filed the bug, and removed (in favor of the msg
header section) again (some weeks IIRC) later.
No headers neve scrolled with the message body. Trust me, I wrote all the header 
display code. It doesn't work since it's not in the same iframe as the message 
body. I looked at the bug your referenced but didn't see any comments describing 
headers scrolling with the message body.
Trust *you*? hah! :)

> It doesn't work since it's not in the same iframe as the message body.

At that time, there were no header section at all. The headers of the normal msg
were displayed in the body iframe just like the headers of forwarded msgs (with
that grey background IIRC). I fetched M14 and M15, both both have the msg header
section. If you don't believe me, grab the source (or a binary, if there is one)
from 2000-04-02.
oh, I completely missed the [nsbeta3-]. Can somebody please tell me how I am
supposed to copy the subject, then? This is a very frequent action when
referring to msgs.
OS: Windows 98 → All
Hardware: PC → All
?? yes trust me...I wrote this stuff I know this has never worked. I just
downloaded M14 and M15 from mozilla.org and sure enough, the headers in the
message pane don't scroll with the message body.

Are we talking about two different things here? 
mscott, I know neither M14 nor M15 show the scrolling headers, I downloaded
these milestones as well. Must have been some time between them. Because they
didn't work too well and disappeared again soon, I think, they were accidently
inserted.
Technically, I don't see a problem for scrolling headers. The headers of
attached msgs scroll as well. You'd just have to output normal msgs like
forwarded ones.
However, personally, I prefer the header pane like it is now.
If it really interests you, build the tree from (around) 2000-04-02.

Anyway, I don't think, the header section will be drop, will it? So, back to
this bug: I can fix this, *if* I know, which widget to use. It has to
- wrap
- shrink to the size of the text
- have selectable text
i.e. a selectable <html>.
In the Cookie Manager the data is selectable just be adding readonly="true" to 
the textfield. Is there something like this for html fields? or is it a bug the 
the html field doesn't use readonly="true" ?
Do they wrap?
*** Bug 48966 has been marked as a duplicate of this bug. ***
Grrr! I just popped in because I have recently begun using Mozilla for news and 
it got old real fast that I couldn't copy message ID's. This is a daily thing 
for me and not being able to select headers is worse than not being able to have 
them scroll with the messages.
Keywords: mozilla1.0
Ditto what Jerry Baker said. Its phenomenally annoying not to be able to
copy/paste From, cc and subject lines. This makes Mozilla mail fairly
useless for me.

Please give up on the headers-in-xul approach and just prepend the header
lines to the message body like 4.x does. Waaah!

*** This bug has been marked as a duplicate of 61497 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate
Status: RESOLVED → VERIFIED
QA Contact: laurel → stephend
Any reason why this old bug is a dup of a newer bug?
No.  Does it really matter? Probably not.
Mass removing self from CC list.
Now I feel sumb because I have to add back. Sorry for the spam.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.