cannot rename local folders because the corresponding files is not deleted on file system



MailNews: Message Display
14 years ago
13 years ago


(Reporter: bruno paul, Unassigned)


Windows 2000

Firefox Tracking Flags

(Not tracked)




14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910 MultiZilla/
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910 MultiZilla/

when you rename local folders, the previous file still exist on file system 

Reproducible: Always
Steps to Reproduce:
1.Have a local folder named "2004" for instance
2.Rename that folder in "2003" : ok
3.Create a new local folder named "2004" in the same place 

Actual Results:  
popup message said this name is already used

Expected Results:  
Delete the local files "2004" AND "2004.msf" when this folder was renamed (this
action only creates new files for the moment)

This problem has multiple impacts :
* when you rename a folder
* when you move a local folder to another subfolder, or the trash, the
"name_of_the_file" still exist in the first location. It is duplicated on the
other location. This will cause doublons when mozilla Mail will restart, because
the "name_of_the_file.msf" will be reconstruct on the previous location.
* when you deleted the local folder and create a new folder with the exact same
name in the same location : the new folder contains all the mails from the
"deleted" folder.

Theses problems exist for years in mozilla Mail.

Comment 2

14 years ago
have you tried a more recent trunk build? I thought I fixed this at one point...
bruno paul, if your folder name in real case contains non-ASCII characters, see
Bug 264071.

Comment 4

14 years ago
no I don't use in my folder name in real case any non-ASCII characters. I use
lower-case, upper-case and numbers.

I haven't tried any nightly build more recent than moz1.7.3

This bug is not exactly a DUP of Bug 65303, because moz does not crash when
reading the phantom mail in the new folder. 
Product: Browser → Seamonkey


13 years ago
Assignee: sspitzer → mail
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.