The default bug view has changed. See this FAQ.

Group by sort feature with sort by "Date" uses "Old Mail" in RSS folders and newsgroup

RESOLVED FIXED in Thunderbird 22.0

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: Kevin Stange, Assigned: alta88)

Tracking

({polish})

unspecified
Thunderbird 22.0
polish
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

855 bytes, patch
bwinton
: review+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041008 Firefox/0.10
Build Identifier: version 0.8 (20041008)

If you group by sort an RSS feed folder on the "Date" field, it uses the string
"Old Mail" for RSS entries aged older than 2 weeks.

Reproducible: Always
Steps to Reproduce:



Expected Results:  
"Old Mail" should probably say "Older Items" or something more generic.

Comment 1

13 years ago
xref bug 263678
or, "Old Articles"?

btw, this also occurs in newsgroups.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0?
Keywords: polish
Summary: Group by sort feature with sort by "Date" uses "Old Mail" in RSS folders → Group by sort feature with sort by "Date" uses "Old Mail" in RSS folders and newsgroup

Updated

13 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 3

12 years ago
*** Bug 267733 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
As noted at the dupe, "Old Mail" doesn't really match the other labels like 
"Today" "Yesterday" etc.
QA Contact: front-end

Updated

9 years ago
Assignee: mscott → nobody
(Assignee)

Comment 5

4 years ago
Created attachment 701469 [details] [diff] [review]
patch


make the string more generic.  it shouldn't be necessary to change the label:
http://mxr.mozilla.org/comm-central/source/mailnews/base/src/nsMsgGroupView.cpp#770
Assignee: nobody → alta88
Attachment #701469 - Flags: review?(mbanner)
Comment on attachment 701469 [details] [diff] [review]
patch

This should get ui-review sign-off as well.

As this is just an improvement in language we don't need to change the string, but r+ is conditional on also posting to mozilla.dev.l10n when this lands to let them know that we've improved the string and they may want to revisit it in their locales.
Attachment #701469 - Flags: ui-review?(bwinton)
Attachment #701469 - Flags: review?(mbanner)
Attachment #701469 - Flags: review+
Comment on attachment 701469 [details] [diff] [review]
patch

Since none of the other strings mention a noun ("Mail", "Messages"), I don't think we should have a noun in this entry either.  So, ui-r-.

But, if you go with "Older", I'll say ui-r=me.  ;)

(Side note: Outlook apparently uses "Older", too.  http://www.peterbe.com/plog/clever-date-formatting#c051111ajor )

Thanks,
Blake.
Attachment #701469 - Flags: ui-review?(bwinton) → ui-review-
(Assignee)

Comment 8

4 years ago
Created attachment 712168 [details] [diff] [review]
patch
Attachment #701469 - Attachment is obsolete: true
Attachment #712168 - Flags: review?(bwinton)
Comment on attachment 712168 [details] [diff] [review]
patch

On the one hand, I think we might want to change the label so that localizers pick up the new string.  On the other hand, we're changing it to match the label itself, and we're not really changing the meaning, just how it sounds.  So I think I'll say r=me, but please double-check in #l10n to see if they would prefer the label to change or not.

Thanks,
Blake.
Attachment #712168 - Flags: review?(bwinton) → review+
Is there any particular reason to not change it for SeaMonkey too?
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/a49f5ca048d9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 22.0
You need to log in before you can comment on or make changes to this bug.