#ifndef XP_MACOSX the Alt+D shortcut, because it doesn't work on Mac

RESOLVED FIXED in Firefox1.5

Status

()

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: rcchicago+allizgub, Assigned: Waldo)

Tracking

unspecified
Firefox1.5
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: help doc fixed, see comment 8)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041009 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041009 Firefox/0.10

Select Location Bar Keyboard Shortcut Opt+D does not work.  Alternate shorcuts
Cmd+L and F6 work as expected.

Reproducible: Always
Steps to Reproduce:
1. Click Opt+D
Actual Results:  
Nothing happens.

Expected Results:  
The Location Bar should be selected.

This worked at one point in previous versions of Firefox (0.8 I believe).

Comment 1

14 years ago
Reproduced on
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041002
Firefox/0.10.1

alt/option + D does not select the location bar as it says it does in Firefox Help.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
did they forget it in bug 231381 ?

Comment 3

14 years ago
I don't think Alt+D is supposed to work on Mac. Does it for Seamonkey?
Accel+L should work, Ctrl+D might even work if they implemented it with
acceesskey="D".

Anyway, it's probably the Firefox help doc that should be changed.
Keywords: helpwanted
Summary: Opt+D shortcut does not work → [Mac] Opt+D shortcut whould work to highlight address bar, or help shouldn't say it does
(Reporter)

Comment 4

14 years ago
Opt+D works on Internet Explorer 5.2 for Mac.  Familiar IE shortcuts like 
Cmd+Return (Ctrl+Enter) and Opt+D (Alt+D) are key features of FireFox, 
especially for former users of IE, and are key to have across platform for 
FireFox to have consistent usability.  This shortcut worked in previous 
versions of FireFox, but stopped working along with the 9 other shortcuts 
which I've submitted separately.  Please do not remove this feature.  It is 
reason #2 why I prefer FireFox over Safari on Mac, and is critical for 
consistency across platforms (I use FireFox on several platforms).

Comment 5

14 years ago
Having option+d select the url bar would be bizarre, as it ordinarily enters a
special character which can be used in type-ahead find, text boxes, etc. This
can lead to some strange behavior--for example, the Sage extension uses
option+s. This means that I can't reliably enter whatever character option+s
produces--most of the time, Sage pops up instead. It's generally not a good idea
to use the option key (by itself) for shortcuts on the Mac.
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Having option+d select the url bar would be bizarre, as it ordinarily enters a
> special character which can be used in type-ahead find, text boxes, etc. This
> can lead to some strange behavior--for example, the Sage extension uses
> option+s. This means that I can't reliably enter whatever character option+s
> produces--most of the time, Sage pops up instead. It's generally not a good idea
> to use the option key (by itself) for shortcuts on the Mac.

Agreed.  I'm changing the component to Help Documentation, which should be
updated to remove the Opt+D Select Location Bar Keyboard Shortcut.
Component: Keyboard Navigation → Help Documentation
This is fallout from the bugfix for Opt/Cmd displaying on the Mac.

(In reply to comment #6)
> Agreed.  I'm changing the component to Help Documentation, which should be
> updated to remove the Opt+D Select Location Bar Keyboard Shortcut.

When you change the component, please use the "Reassign bug to owner and QA
contact of selected component" option so as to make sure the QA contact changes
accordingly.  Several people watch firefox.help-documentation@bugs to track Help
bugs, and there's no way we'll see these bugs unless we get mail about them (or
if we happen to notice them on saved Bugzilla queries).

I might get to a patch for this pretty soon...as there shouldn't be any wording
changes I'll probably just check in the fix and bypass review (assuming I make
the patch).
QA Contact: jruderman → firefox.help-documentation
(In reply to comment #7)
> This is fallout from the bugfix for Opt/Cmd displaying on the Mac.

Okay, maybe it really wasn't. ;-)

Anyways, fix checked into branch and trunk to remove the shortcut from Help.  If
Opt+D isn't good for the Mac, you should probably make it official (or
better-documented, if that's how you choose to see it) by changing the
definition of the shortcut in browser/base/content/browser-sets.inc by enclosing
it in #ifndef XP_MACOSX/#endif:

http://lxr.mozilla.org/aviarybranch/source/browser/base/content/browser-sets.inc#201

Please report other mistakes in Mac keyboard shortcuts while you're at it.  No
one working on Help uses a Mac, so we're sort of stuck with what we can derive
from source code (unless other people tell us otherwise), which doesn't consist
of every Mac shortcut.
Summary: [Mac] Opt+D shortcut whould work to highlight address bar, or help shouldn't say it does → [Mac] Opt+D shortcut should work to highlight address bar, or help shouldn't say it does
Created attachment 161907 [details] [diff] [review]
#ifndef XP_MACOSX for the Alt+D shortcut

This is against trunk.	I don't know or really care if it applies to aviary,
because aviary can live without this (and if it can't, porting the patch is
trivial).
Attachment #161907 - Flags: review?(aaronleventhal)

Updated

14 years ago
Attachment #161907 - Flags: review?(aaronleventhal) → review?(mconnor)
Comment on attachment 161907 [details] [diff] [review]
#ifndef XP_MACOSX for the Alt+D shortcut

Mike doesn't have time to review anything right now, even things as trivial as
this.  I asked for a review of a patch that directly corresponded to a patch
for the same problem in another area of the app.  You'll need to find someone
else to do the review for you.
Attachment #161907 - Flags: review?(mconnor)

Comment 11

14 years ago
The Help doc is fixed, see comment 8. -> Keyboard Navigation.
Assignee: aaronleventhal → jwalden+bmo
Component: Help Documentation → Keyboard Navigation
Keywords: helpwanted
QA Contact: firefox.help-documentation → jruderman
Summary: [Mac] Opt+D shortcut should work to highlight address bar, or help shouldn't say it does → #ifndef XP_MACOSX the Alt+D shortcut, becuase it doesn't work on Mac
Whiteboard: help doc fixed, see comment 8
Assignee: jwalden+bmo → aaronleventhal
Comment on attachment 161907 [details] [diff] [review]
#ifndef XP_MACOSX for the Alt+D shortcut

should be reviewed by Aaron.
Attachment #161907 - Flags: review?(aaronleventhal)

Comment 13

14 years ago
I'm fine with removing Alt/Option+D for Mac, based on the comment that
option+letter is used to enter extended chars. However, I had wanted the code to
be r='d by a front-end person like mconnor.

Updated

14 years ago
Keywords: helpwanted
Comment on attachment 161907 [details] [diff] [review]
#ifndef XP_MACOSX for the Alt+D shortcut

lets move it to vladimir
Attachment #161907 - Flags: review?(aaronleventhal) → review?(vladimir)
Attachment #161907 - Flags: review?(vladimir) → review?(mconnor)
Comment on attachment 161907 [details] [diff] [review]
#ifndef XP_MACOSX for the Alt+D shortcut

hmm, as much as the key-compatibility with other Mac browsers is a "good thing"
the Opt+whatever shortcuts obviously shouldn't be used in this case.

r=mconnor@steelgryphon.com
Attachment #161907 - Flags: review?(mconnor) → review+

Comment 16

14 years ago
-> Jeff.
Assignee: aaronleventhal → jwalden+bmo
Keywords: helpwanted
Summary: #ifndef XP_MACOSX the Alt+D shortcut, becuase it doesn't work on Mac → #ifndef XP_MACOSX the Alt+D shortcut, because it doesn't work on Mac
Target Milestone: --- → Firefox1.1

Comment 17

14 years ago
Checking in mozilla/browser/base/content/browser-sets.inc;
/cvsroot/mozilla/browser/base/content/browser-sets.inc,v  <--  browser-sets.inc
new revision: 1.30; previous revision: 1.29
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.