Closed Bug 263776 Opened 18 years ago Closed 16 years ago

height of div collapses when focusing link inside div with floating image

Categories

(Core :: Layout: Floats, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; @AB_CD@; rv:1.8a4) Gecko/20041008 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; @AB_CD@; rv:1.8a4) Gecko/20041008 Firefox/0.9.1+

On the URL testcase: Focus the link "another award". You'll see the height of
the div collapsing as if there was no <br style="clear:both">.

The "diff -w" fix from bug 209694 doesn't seem to fix this bug (tested in my
debug build).

I'll attach a testcase.

(This only happens in recent 1.8a Mozilla builds, people)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Attached file Testcase
This doesn't happen in 2004-07-11 builds, but it happens in 2004-07-18 builds,
so it is most likely an already existing bug that got visible by fixing bug
151375 (which introduced reflow when focusing something).
Blocks: 261196
Keywords: testcase
Mozilla Windows Trunk Nightly Build Regression Window
Pass: 2004071609
Fail: 2004071808
*** Bug 295409 has been marked as a duplicate of this bug. ***
All/All, per dupe.
OS: Windows XP → All
Hardware: PC → All
As of 14 September 2005 (Firefox 1.5b1) this regression remains unresolved.
Testing reveals that it's in the trunk. It's a rendering regression that's
almost a year old, so I'm voting for setting blocking 1.8b5 in hopes that it
gets assigned and looked at. It's worthwhile to note that any character entity
or block-level element that gets introduced after the floating element in
question causes the div to flow correctly.
Blocks: 307387
No longer blocks: 307387
I see this problem in Firefox 1.5 Beta 2, maximized in 1152 × 864, when focusing
on the "blowtorches" link:
http://weblogs.mozillazine.org/gerv/archives/2005/10/trophy_picture.html
This is worksforme, using a 2006-12-06 trunk build (a build before the reflow branch landed).
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.